{"answers":{"affected":"2 open source packages ship an affected version, including pem.","exploited":"There is no known exploitation of GHSA-pgcr-7wm4-mcv6 in the wild and no public exploit code.","fix":"Upgrade pem to 1.13.2 or later.","what":"GHSA-pgcr-7wm4-mcv6 is a vulnerability in pem, published on 4 Jun 2019. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pgcr-7wm4-mcv6 and fix it if it is affected.\n\nWhat it is: GHSA-pgcr-7wm4-mcv6 is a vulnerability in pem, published on 4 Jun 2019. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pgcr-7wm4-mcv6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pem (npm): affected all versions; fixed in 1.13.2\n- pem (npm): affected all versions; fixed in 1.13.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pgcr-7wm4-mcv6/ (Markdown: https://insights.sbomify.com/GHSA-pgcr-7wm4-mcv6/index.md)","id":"GHSA-pgcr-7wm4-mcv6","markdown":"https://insights.sbomify.com/GHSA-pgcr-7wm4-mcv6/index.md","name":"GHSA-pgcr-7wm4-mcv6","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js PEM library","requires_auth":"none","summary":"Local attackers can read sensitive PKCS12 passwords from temporary files created by the pem library, exposing cryptographic keys.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `pem` before 1.13.2 expose sensitive data when the `readPkcs12` is used. \n\nThe `readPkcs12` function reads the certificate and key data from a pkcs12 file using the encryption password. As part of this process it creates a globally readable file with a filename of 20 random 0-f characters in the temporary directory containing the password which is then read by OpenSSL. The file containing the password is never cleaned up after it is used giving access to the pkcs12 password to any other users with access to read files from the system.\n\n## Recommendation\n\nUpdate to version 1.13.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Sensitive Data Exposure in pem","id":"GHSA-pgcr-7wm4-mcv6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.13.2"],"introduced":["0"],"last_affected":[],"package":"pem","purl":null,"source":"GHSA-pgcr-7wm4-mcv6"},{"ecosystem":"npm","fixed":["1.13.2"],"introduced":["0"],"last_affected":[],"package":"pem","purl":"pkg:npm/pem","source":"GHSA-pgcr-7wm4-mcv6"}],"products":null,"published":"2019-06-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Local attackers can read sensitive PKCS12 passwords from temporary files created by the pem library, exposing cryptographic keys.","url":"https://insights.sbomify.com/GHSA-pgcr-7wm4-mcv6/"}