{"answers":{"affected":"2 open source packages ship an affected version, including dompurify.","exploited":"There is no known exploitation of GHSA-pgjv-jrg2-gq3v in the wild and no public exploit code.","fix":"Upgrade dompurify to 2.2.2 or later.","what":"GHSA-pgjv-jrg2-gq3v is a cross-site scripting vulnerability in dompurify, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-pgjv-jrg2-gq3v and fix it if it is affected.\n\nWhat it is: GHSA-pgjv-jrg2-gq3v is a cross-site scripting vulnerability in dompurify, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-pgjv-jrg2-gq3v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dompurify (PyPI): affected all versions; fixed in 2.2.2\n- dompurify (PyPI): affected all versions; fixed in 2.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pgjv-jrg2-gq3v/ (Markdown: https://insights.sbomify.com/GHSA-pgjv-jrg2-gq3v/index.md)","id":"GHSA-pgjv-jrg2-gq3v","markdown":"https://insights.sbomify.com/GHSA-pgjv-jrg2-gq3v/index.md","name":"GHSA-pgjv-jrg2-gq3v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript sanitization library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in a victim's browser via crafted SVG content processed by the library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"dompurify prior to version 2.2.2 is vulnerable to cross-site scripting when converting from SVG namespace.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"dompurify vulnerable to Cross-site Scripting","id":"GHSA-pgjv-jrg2-gq3v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"dompurify","purl":null,"source":"GHSA-pgjv-jrg2-gq3v"},{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"dompurify","purl":"pkg:pypi/dompurify","source":"GHSA-pgjv-jrg2-gq3v"}],"products":null,"published":"2023-01-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can execute arbitrary scripts in a victim's browser via crafted SVG content processed by the library.","url":"https://insights.sbomify.com/GHSA-pgjv-jrg2-gq3v/"}