{"answers":{"affected":"2 open source packages ship an affected version, including @anthropic-ai/claude-code.","exploited":"There is no known exploitation of GHSA-ph6w-f82w-28w6 in the wild and no public exploit code.","fix":"Upgrade @anthropic-ai/claude-code to 1.0.87 or later.","what":"GHSA-ph6w-f82w-28w6 is a vulnerability in @anthropic-ai/claude-code, published on 3 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-ph6w-f82w-28w6 and fix it if it is affected.\n\nWhat it is: GHSA-ph6w-f82w-28w6 is a vulnerability in @anthropic-ai/claude-code, published on 3 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-ph6w-f82w-28w6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.87\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.87\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-ph6w-f82w-28w6/ (Markdown: https://insights.sbomify.com/GHSA-ph6w-f82w-28w6/index.md)","id":"GHSA-ph6w-f82w-28w6","markdown":"https://insights.sbomify.com/GHSA-ph6w-f82w-28w6/index.md","name":"GHSA-ph6w-f82w-28w6","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Claude Code CLI","requires_auth":"none","summary":"Insufficient warning allowed users to inadvertently permit arbitrary code execution when starting Claude Code in untrusted directories.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"When Claude Code was started in a new directory, it displayed a warning asking, \"Do you trust the files in this folder?\". This warning did not properly document that selecting \"Yes, proceed\" would allow Claude Code to execute files in the folder without additional confirmation. This may not have been clear to a user so we have updated the warning to clarify this functionality. \n\nUsers on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.\n\nThank you to https://hackerone.com/avivdon for reporting this issue!","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Claude Code Vulnerable to Arbitrary Code Execution Due to Insufficient Startup Warning","id":"GHSA-ph6w-f82w-28w6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.87"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":null,"source":"GHSA-ph6w-f82w-28w6"},{"ecosystem":"npm","fixed":["1.0.87"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":"pkg:npm/%40anthropic-ai/claude-code","source":"GHSA-ph6w-f82w-28w6"}],"products":null,"published":"2025-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insufficient warning allowed users to inadvertently permit arbitrary code execution when starting Claude Code in untrusted directories.","url":"https://insights.sbomify.com/GHSA-ph6w-f82w-28w6/"}