{"answers":{"affected":"1 open source package ship an affected version, including bottlerocket/update-operator.","exploited":"There is no known exploitation of GHSA-pj34-fpw3-83qj in the wild and no public exploit code.","fix":"Upgrade bottlerocket/update-operator to 1.1.0 or later.","what":"GHSA-pj34-fpw3-83qj is a memory corruption vulnerability in bottlerocket/update-operator, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pj34-fpw3-83qj and fix it if it is affected.\n\nWhat it is: GHSA-pj34-fpw3-83qj is a memory corruption vulnerability in bottlerocket/update-operator, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pj34-fpw3-83qj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bottlerocket/update-operator (crates.io): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pj34-fpw3-83qj/ (Markdown: https://insights.sbomify.com/GHSA-pj34-fpw3-83qj/index.md)","id":"GHSA-pj34-fpw3-83qj","markdown":"https://insights.sbomify.com/GHSA-pj34-fpw3-83qj/index.md","name":"GHSA-pj34-fpw3-83qj","record":{"aliases":[],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Bottlerocket update operator","requires_auth":"none","summary":"A read buffer overflow in OpenSSL X.509 verification can cause crashes in Bottlerocket update operators, requiring an upgrade to remove OpenSSL.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A read buffer overflow can be triggered in OpenSSL X.509 verification during name constraint checking. Note that this occurs after the certificate chain has been verified and would require a compromised CA. This can cause a client or agent compiled with OpenSSL to crash unexpectedly. OpenSSL has been removed in bottlerocket/update-operator version 1.1.0 in favor of Rust-based TLS using rustls.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"bottlerocket dependency openssl is vulnerable to read buffer overflow via X.509 verification","id":"GHSA-pj34-fpw3-83qj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"bottlerocket/update-operator","purl":"pkg:cargo/bottlerocket/update-operator","source":"GHSA-pj34-fpw3-83qj"}],"products":null,"published":"2023-02-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A read buffer overflow in OpenSSL X.509 verification can cause crashes in Bottlerocket update operators, requiring an upgrade to remove OpenSSL.","url":"https://insights.sbomify.com/GHSA-pj34-fpw3-83qj/"}