{"answers":{"affected":"2 open source packages ship an affected version, including shopware/platform.","exploited":"There is no known exploitation of GHSA-pjj4-jjgc-h3r8 in the wild and no public exploit code.","fix":"Upgrade shopware/platform to 6.3.5.2 or later.","what":"GHSA-pjj4-jjgc-h3r8 is a missing authorization vulnerability in shopware/platform, published on 12 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pjj4-jjgc-h3r8 and fix it if it is affected.\n\nWhat it is: GHSA-pjj4-jjgc-h3r8 is a missing authorization vulnerability in shopware/platform, published on 12 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pjj4-jjgc-h3r8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.2\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pjj4-jjgc-h3r8/ (Markdown: https://insights.sbomify.com/GHSA-pjj4-jjgc-h3r8/index.md)","id":"GHSA-pjj4-jjgc-h3r8","markdown":"https://insights.sbomify.com/GHSA-pjj4-jjgc-h3r8/index.md","name":"GHSA-pjj4-jjgc-h3r8","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"low_privilege","summary":"Authenticated attackers can execute remote code via the plugin manager due to missing ACL permissions, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nAuthenticated remote code execution using plugin manager without ACL permissions.\n\n### Patches\nWe recommend to update to the current version 6.3.5.2. You can get the update to 6.3.5.2 regularly via the Auto-Updater or directly via the download overview.\n\nhttps://www.shopware.com/en/download/#shopware-6\n\n### Workarounds\nFor older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.\n\nhttps://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659\n\n### For more information\nhttps://docs.shopware.com/en/shopware-6-en/security-updates/security-update-03-2021","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Authenticated remote code execution","id":"GHSA-pjj4-jjgc-h3r8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["6.3.5.2"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":null,"source":"GHSA-pjj4-jjgc-h3r8"},{"ecosystem":"Packagist","fixed":["6.3.5.2"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":"pkg:composer/shopware/platform","source":"GHSA-pjj4-jjgc-h3r8"}],"products":null,"published":"2021-03-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Authenticated attackers can execute remote code via the plugin manager due to missing ACL permissions, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/GHSA-pjj4-jjgc-h3r8/"}