# GHSA-pjj4-jjgc-h3r8: Authenticated remote code execution

> Authenticated attackers can execute remote code via the plugin manager due to missing ACL permissions, requiring an upgrade to the latest version.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2021

## What is GHSA-pjj4-jjgc-h3r8?

GHSA-pjj4-jjgc-h3r8 is a missing authorization vulnerability in shopware/platform, published on 12 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact
Authenticated remote code execution using plugin manager without ACL permissions.

### Patches
We recommend to update to the current version 6.3.5.2. You can get the update to 6.3.5.2 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

### Workarounds
For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

### For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-03-2021

## Which versions are affected by GHSA-pjj4-jjgc-h3r8?

2 open source packages ship an affected version, including shopware/platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/platform` | Packagist | All versions | 6.3.5.2 |
| `shopware/platform` | Packagist | All versions | 6.3.5.2 |

## How do I fix GHSA-pjj4-jjgc-h3r8?

Upgrade shopware/platform to 6.3.5.2 or later.

## Is GHSA-pjj4-jjgc-h3r8 being exploited?

There is no known exploitation of GHSA-pjj4-jjgc-h3r8 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-pjj4-jjgc-h3r8 and fix it if it is affected.

What it is: GHSA-pjj4-jjgc-h3r8 is a missing authorization vulnerability in shopware/platform, published on 12 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-pjj4-jjgc-h3r8 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.2
- shopware/platform (Packagist): affected all versions; fixed in 6.3.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-pjj4-jjgc-h3r8/ (Markdown: https://insights.sbomify.com/GHSA-pjj4-jjgc-h3r8/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-pjj4-jjgc-h3r8

---
From sbomify Insights: https://insights.sbomify.com/GHSA-pjj4-jjgc-h3r8/
Summaries are generated and may contain mistakes; the official description above is the record.
