{"answers":{"affected":"2 open source packages ship an affected version, including friendsofsymfony/user-bundle.","exploited":"There is no known exploitation of GHSA-pjx8-984p-7p3x in the wild and no public exploit code.","fix":"Upgrade friendsofsymfony/user-bundle to 1.3.5 or later.","what":"GHSA-pjx8-984p-7p3x is a vulnerability in friendsofsymfony/user-bundle, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pjx8-984p-7p3x and fix it if it is affected.\n\nWhat it is: GHSA-pjx8-984p-7p3x is a vulnerability in friendsofsymfony/user-bundle, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pjx8-984p-7p3x in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- friendsofsymfony/user-bundle (Packagist): affected from 1.0.0; fixed in 1.3.5\n- friendsofsymfony/user-bundle (Packagist): affected from 1.0.0; fixed in 1.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pjx8-984p-7p3x/ (Markdown: https://insights.sbomify.com/GHSA-pjx8-984p-7p3x/index.md)","id":"GHSA-pjx8-984p-7p3x","markdown":"https://insights.sbomify.com/GHSA-pjx8-984p-7p3x/index.md","name":"GHSA-pjx8-984p-7p3x","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony User Bundle","requires_auth":"none","summary":"Weak token generation in FOSUserBundle allows attackers to predict email confirmation and password reset tokens, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Description\nBecause of the usage of base_convert which looses precision for large inputs, the entropy of tokens generated by FOSUserBundle for the email confirmation and password resetting is lost. This makes these tokens much less random than they are expected to be, and so not cryptographically safe.\n\n### Resolution\nThe token generation logic used in the 2.0.x branch based on base64 encoding has been backported. This changes the range of characters used in the token. Any route placeholder expected to match a token generated by FOSUserBundle must be updated to allow dashes, which are not allowed by \\w in regexes. A \\w+ requirement should so become [\\w\\-]+.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"FOSUserBundle Entropy is lost in the TokenGenerator","id":"GHSA-pjx8-984p-7p3x","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["1.0.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":null,"source":"GHSA-pjx8-984p-7p3x"},{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["1.0.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":"pkg:composer/friendsofsymfony/user-bundle","source":"GHSA-pjx8-984p-7p3x"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Weak token generation in FOSUserBundle allows attackers to predict email confirmation and password reset tokens, potentially leading to account takeover.","url":"https://insights.sbomify.com/GHSA-pjx8-984p-7p3x/"}