{"answers":{"affected":"2 open source packages ship an affected version, including thelia/backoffice-default-template.","exploited":"There is no known exploitation of GHSA-pp7v-wxx9-hm6r in the wild and no public exploit code.","fix":"Upgrade thelia/backoffice-default-template to 2.1.2 or later.","what":"GHSA-pp7v-wxx9-hm6r is a cross-site scripting vulnerability in thelia/backoffice-default-template, published on 30 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-pp7v-wxx9-hm6r and fix it if it is affected.\n\nWhat it is: GHSA-pp7v-wxx9-hm6r is a cross-site scripting vulnerability in thelia/backoffice-default-template, published on 30 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-pp7v-wxx9-hm6r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- thelia/backoffice-default-template (Packagist): affected from 2.1.0; fixed in 2.1.2\n- thelia/backoffice-default-template (Packagist): affected from 2.1.0; fixed in 2.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pp7v-wxx9-hm6r/ (Markdown: https://insights.sbomify.com/GHSA-pp7v-wxx9-hm6r/index.md)","id":"GHSA-pp7v-wxx9-hm6r","markdown":"https://insights.sbomify.com/GHSA-pp7v-wxx9-hm6r/index.md","name":"GHSA-pp7v-wxx9-hm6r","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Thelia BackOffice","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into the Thelia BackOffice error template, potentially compromising admin sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The BackOffice of Thelia (`error.html` template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Thelia BackOffice default template vulnerable to Cross-site Scripting","id":"GHSA-pp7v-wxx9-hm6r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.1.2"],"introduced":["2.1.0"],"last_affected":[],"package":"thelia/backoffice-default-template","purl":null,"source":"GHSA-pp7v-wxx9-hm6r"},{"ecosystem":"Packagist","fixed":["2.1.2"],"introduced":["2.1.0"],"last_affected":[],"package":"thelia/backoffice-default-template","purl":"pkg:composer/thelia/backoffice-default-template","source":"GHSA-pp7v-wxx9-hm6r"}],"products":null,"published":"2024-05-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can inject malicious scripts into the Thelia BackOffice error template, potentially compromising admin sessions.","url":"https://insights.sbomify.com/GHSA-pp7v-wxx9-hm6r/"}