# GHSA-pp84-v3mw-gg4w: Taipy 3.1.1 affected by CVEs on flask-core and pymongo

> Taipy library is vulnerable via outdated Flask and PyMongo dependencies, allowing potential code execution or data access; upgrade required.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 27 Aug 2024

## What is GHSA-pp84-v3mw-gg4w?

GHSA-pp84-v3mw-gg4w is a vulnerability in taipy, published on 27 Aug 2024. It can be exploited over the network.

### Official description

### Summary
Indirect CVEs affect Taipy 3.1.1

### Details
Taipy 3.1.1 is affected by two existing CVEs:
CVE-2024-1681 affects flask-core <4.0.1 and taipy 3.1.1 needs <=4.0.0
CVE-2024-5629 affects pymongo <4.6.3 and taipy 3.1.1 needs <=4.6.1

Please see References for further details.

### Patch
please upgrade to the following versions:

Fixed on patch versions: >=3.1.2
and on major releases: >=4.0.0

### Impact
pre-commit breaks when using dependency Taipy 3.1.1

## Which versions are affected by GHSA-pp84-v3mw-gg4w?

2 open source packages ship an affected version, including taipy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `taipy` | PyPI | All versions | 4.0.0 |
| `taipy` | PyPI | All versions | 4.0.0 |

## How do I fix GHSA-pp84-v3mw-gg4w?

Upgrade taipy to 4.0.0 or later.

## Is GHSA-pp84-v3mw-gg4w being exploited?

There is no known exploitation of GHSA-pp84-v3mw-gg4w in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-pp84-v3mw-gg4w and fix it if it is affected.

What it is: GHSA-pp84-v3mw-gg4w is a vulnerability in taipy, published on 27 Aug 2024. It can be exploited over the network.
Exploitation: There is no known exploitation of GHSA-pp84-v3mw-gg4w in the wild and no public exploit code.

Affected packages and fixed versions:
- taipy (PyPI): affected all versions; fixed in 4.0.0
- taipy (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-pp84-v3mw-gg4w/ (Markdown: https://insights.sbomify.com/GHSA-pp84-v3mw-gg4w/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-pp84-v3mw-gg4w

---
From sbomify Insights: https://insights.sbomify.com/GHSA-pp84-v3mw-gg4w/
Summaries are generated and may contain mistakes; the official description above is the record.
