{"answers":{"affected":"2 open source packages ship an affected version, including simplesamlphp/simplesamlphp.","exploited":"There is no known exploitation of GHSA-ppm4-r2vc-pg74 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/simplesamlphp to 1.17.8 or later.","what":"GHSA-ppm4-r2vc-pg74 is a vulnerability in simplesamlphp/simplesamlphp, published on 28 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-ppm4-r2vc-pg74 and fix it if it is affected.\n\nWhat it is: GHSA-ppm4-r2vc-pg74 is a vulnerability in simplesamlphp/simplesamlphp, published on 28 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-ppm4-r2vc-pg74 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/simplesamlphp (Packagist): affected from 1.17.0; fixed in 1.17.8\n- simplesamlphp/simplesamlphp (Packagist): affected from 1.17.0; fixed in 1.17.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-ppm4-r2vc-pg74/ (Markdown: https://insights.sbomify.com/GHSA-ppm4-r2vc-pg74/index.md)","id":"GHSA-ppm4-r2vc-pg74","markdown":"https://insights.sbomify.com/GHSA-ppm4-r2vc-pg74/index.md","name":"GHSA-ppm4-r2vc-pg74","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"SimpleSAMLphp","requires_auth":"none","summary":"Unauthenticated attackers can access phpinfo output via an unprotected admin endpoint if the experimental UI and admin module are enabled.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Background\nSimpleSAMLphp 1.17 includes a preview of the new user interface to be included in the future version 2.0. This new user interface can be enabled by setting the usenewui configuration option to true, and it includes a new admin interface in a module called admin, which can be disabled.\n\n### Description\nThe new admin interface includes a way to view information about the host where SimpleSAMLphp is installed, by means of the phpinfo() PHP function. An endpoint that exposes the output of that function is included in the admin module for easier debugging.\n\nThe aforementioned endpoint had no checks for administrator privileges. This would allow any individual to access the given endpoint without authenticating, gathering information about the affected system.\n\n### Affected versions\nAll SimpleSAMLphp 1.17 versions up to 1.17.7 are affected, provided that the new, experimental use interface is enabled, together with the new admin module.\n\n### Impact\nAn attacker could leverage this issue by accessing the unprotected endpoint and gather intelligence about the host where SimpleSAMLphp is deployed, using it later for their own advantage in case other issues arise.\n\nHowever, the impact of this issue is deemed as low, given that the new user interface must be explicitly enabled by means of the usenewui configuration option, and the new admin module must also be enabled.\n\n### Resolution\nUpgrade to SimpleSAMLphp 1.17.8 or 1.18. This can be done by downloading the package, or by running composer update. Refer to the documentation for instructions on how to run composer.\n\nAlternatively, the issue can be mitigated by either disabling the new user interface by setting the usenewui configuration option to false, or by disabling the admin module in the configuration:\n```\n    'module.enable' =\u003e [\n        ...\n        'admin' =\u003e false,\n        ...\n    ],\n```","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"SimpleSAMLphp Information Disclosure vulnerability","id":"GHSA-ppm4-r2vc-pg74","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.17.8"],"introduced":["1.17.0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp","purl":null,"source":"GHSA-ppm4-r2vc-pg74"},{"ecosystem":"Packagist","fixed":["1.17.8"],"introduced":["1.17.0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp","purl":"pkg:composer/simplesamlphp/simplesamlphp","source":"GHSA-ppm4-r2vc-pg74"}],"products":null,"published":"2024-05-28","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Unauthenticated attackers can access phpinfo output via an unprotected admin endpoint if the experimental UI and admin module are enabled.","url":"https://insights.sbomify.com/GHSA-ppm4-r2vc-pg74/"}