{"answers":{"affected":"3 open source packages ship an affected version, including github.com/inspektor-gadget/inspektor-gadget.","exploited":"There is no known exploitation of GHSA-pv22-fqcj-7xwh in the wild and no public exploit code.","fix":"Upgrade github.com/inspektor-gadget/inspektor-gadget to 0.40.0 or later.","what":"GHSA-pv22-fqcj-7xwh is a vulnerability in github.com/inspektor-gadget/inspektor-gadget, published on 6 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-pv22-fqcj-7xwh and fix it if it is affected.\n\nWhat it is: GHSA-pv22-fqcj-7xwh is a vulnerability in github.com/inspektor-gadget/inspektor-gadget, published on 6 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-pv22-fqcj-7xwh in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/inspektor-gadget/inspektor-gadget (Go): affected from 0.31.0; fixed in 0.40.0\n- github.com/inspektor-gadget/inspektor-gadget (Go): affected from 0.31.0; fixed in 0.40.0\n- github.com/inspektor-gadget/inspektor-gadget (Go): affected from 0.31.0; fixed in 0.40.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pv22-fqcj-7xwh/ (Markdown: https://insights.sbomify.com/GHSA-pv22-fqcj-7xwh/index.md)","id":"GHSA-pv22-fqcj-7xwh","markdown":"https://insights.sbomify.com/GHSA-pv22-fqcj-7xwh/index.md","name":"GHSA-pv22-fqcj-7xwh","record":{"aliases":["GO-2025-3665"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Kubernetes security tool","requires_auth":"low_privilege","summary":"A malicious client can bypass Inspektor Gadget security policies, allowing unauthorized gadget execution or image pulling if the client has access to the server or cluster.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Security policies like [`allowed-gadgets`](https://inspektor-gadget.io/docs/latest/reference/restricting-gadgets),  [`disallow-pulling`](https://inspektor-gadget.io/docs/latest/reference/disallow-pulling), [`verify-image`](https://inspektor-gadget.io/docs/latest/reference/verify-assets#verify-image-based-gadgets) can be bypassed by a malicious client.\n\n### Impact\n\nUsers running `ig` in daemon mode or IG on Kubernetes that rely on any of the features mentioned above are vulnerable to this issue. In order to exploit this, the client needs access to the server, like the correct TLS certificates on the `ig daemon` case or access to the cluster in the Kubernetes case. \n\n### Patches\n\nThe issue has been fixed in v0.40.0\n\n### Workarounds\n\nThere is not known workaround to fix it.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Inspektor Gadget Security Policies Can be Bypassed","id":"GHSA-pv22-fqcj-7xwh","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.40.0"],"introduced":["0.31.0"],"last_affected":[],"package":"github.com/inspektor-gadget/inspektor-gadget","purl":null,"source":"GHSA-pv22-fqcj-7xwh"},{"ecosystem":"Go","fixed":["0.40.0"],"introduced":["0.31.0"],"last_affected":[],"package":"github.com/inspektor-gadget/inspektor-gadget","purl":"pkg:golang/github.com/inspektor-gadget/inspektor-gadget","source":"GHSA-pv22-fqcj-7xwh"},{"ecosystem":"Go","fixed":["0.40.0"],"introduced":["0.31.0"],"last_affected":[],"package":"github.com/inspektor-gadget/inspektor-gadget","purl":"pkg:golang/github.com/inspektor-gadget/inspektor-gadget","source":"GO-2025-3665"}],"products":null,"published":"2025-05-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious client can bypass Inspektor Gadget security policies, allowing unauthorized gadget execution or image pulling if the client has access to the server or cluster.","url":"https://insights.sbomify.com/GHSA-pv22-fqcj-7xwh/"}