{"answers":{"affected":"3 open source packages ship an affected version, including libcrux-poly1305.","exploited":"There is no known exploitation of GHSA-pv9v-5j35-xwcr in the wild and no public exploit code.","fix":"Upgrade libcrux-poly1305 to 0.0.5 or later.","what":"GHSA-pv9v-5j35-xwcr is a denial of service vulnerability in libcrux-poly1305, published on 4 Mar 2026."},"fix_prompt":"Check this codebase for GHSA-pv9v-5j35-xwcr and fix it if it is affected.\n\nWhat it is: GHSA-pv9v-5j35-xwcr is a denial of service vulnerability in libcrux-poly1305, published on 4 Mar 2026. \nExploitation: There is no known exploitation of GHSA-pv9v-5j35-xwcr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libcrux-poly1305 (crates.io): affected all versions; fixed in 0.0.5\n- libcrux-poly1305 (crates.io): affected all versions; fixed in 0.0.5\n- libcrux-poly1305 (crates.io): affected from 0.0.0-0; fixed in 0.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pv9v-5j35-xwcr/ (Markdown: https://insights.sbomify.com/GHSA-pv9v-5j35-xwcr/index.md)","id":"GHSA-pv9v-5j35-xwcr","markdown":"https://insights.sbomify.com/GHSA-pv9v-5j35-xwcr/index.md","name":"GHSA-pv9v-5j35-xwcr","record":{"aliases":["RUSTSEC-2026-0073"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust crypto library","requires_auth":"none","summary":"Incorrect key length constant causes panics in standalone MAC operations, leading to denial of service for applications using libcrux-poly1305 directly.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"An incorrect constant for the key length in libcrux-poly1305 caused the standalone MAC function `libcrux_poly1305::mac` to always panic with an out-of-bounds memory access.\n\n## Impact\nApplications wishing to use libcrux-poly1305 as a standalone MAC would experience panics. The use of libcrux-poly1305 in libcrux-chacha20poly1305 is unaffected.\n\n## Mitigation\nStarting from version `0.0.5`, the correct value is used for the key length constant.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"libcrux Panics During Standalone MAC Operations","id":"GHSA-pv9v-5j35-xwcr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.0.5"],"introduced":["0"],"last_affected":[],"package":"libcrux-poly1305","purl":null,"source":"GHSA-pv9v-5j35-xwcr"},{"ecosystem":"crates.io","fixed":["0.0.5"],"introduced":["0"],"last_affected":[],"package":"libcrux-poly1305","purl":"pkg:cargo/libcrux-poly1305","source":"GHSA-pv9v-5j35-xwcr"},{"ecosystem":"crates.io","fixed":["0.0.5"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libcrux-poly1305","purl":"pkg:cargo/libcrux-poly1305","source":"RUSTSEC-2026-0073"}],"products":null,"published":"2026-03-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Incorrect key length constant causes panics in standalone MAC operations, leading to denial of service for applications using libcrux-poly1305 directly.","url":"https://insights.sbomify.com/GHSA-pv9v-5j35-xwcr/"}