{"answers":{"affected":"2 open source packages ship an affected version, including phpxmlrpc/phpxmlrpc.","exploited":"There is no known exploitation of GHSA-pxqj-xrv5-qvjf in the wild and no public exploit code.","fix":"Upgrade phpxmlrpc/phpxmlrpc to 4.9.2 or later.","what":"GHSA-pxqj-xrv5-qvjf is a cross-site scripting vulnerability in phpxmlrpc/phpxmlrpc, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-pxqj-xrv5-qvjf and fix it if it is affected.\n\nWhat it is: GHSA-pxqj-xrv5-qvjf is a cross-site scripting vulnerability in phpxmlrpc/phpxmlrpc, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-pxqj-xrv5-qvjf in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpxmlrpc/phpxmlrpc (Packagist): affected all versions; fixed in 4.9.2\n- phpxmlrpc/phpxmlrpc (Packagist): affected all versions; fixed in 4.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-pxqj-xrv5-qvjf/ (Markdown: https://insights.sbomify.com/GHSA-pxqj-xrv5-qvjf/index.md)","id":"GHSA-pxqj-xrv5-qvjf","markdown":"https://insights.sbomify.com/GHSA-pxqj-xrv5-qvjf/index.md","name":"GHSA-pxqj-xrv5-qvjf","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP XML-RPC library","requires_auth":"none","summary":"Developers using the bundled XML-RPC debugger in this PHP library are vulnerable to XSS if the debugger is exposed to web requests.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The bundled xml-rpc debugger is susceptible to XSS attacks.\n\nSince the debugger is not designed to be exposed to end users but only to the developers using this library, and in the default configuration it is not exposed to requests from the web, the likelihood of exploitation may be low.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"XML-RPC for PHP's debugger vulnerable to possible XSS attack","id":"GHSA-pxqj-xrv5-qvjf","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.9.2"],"introduced":["0"],"last_affected":[],"package":"phpxmlrpc/phpxmlrpc","purl":null,"source":"GHSA-pxqj-xrv5-qvjf"},{"ecosystem":"Packagist","fixed":["4.9.2"],"introduced":["0"],"last_affected":[],"package":"phpxmlrpc/phpxmlrpc","purl":"pkg:composer/phpxmlrpc/phpxmlrpc","source":"GHSA-pxqj-xrv5-qvjf"}],"products":null,"published":"2023-01-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Developers using the bundled XML-RPC debugger in this PHP library are vulnerable to XSS if the debugger is exposed to web requests.","url":"https://insights.sbomify.com/GHSA-pxqj-xrv5-qvjf/"}