{"answers":{"affected":"4 open source packages ship an affected version, including handlebars.","exploited":"There is no known exploitation of GHSA-q2c6-c6pm-g3gh in the wild and no public exploit code.","fix":"Upgrade handlebars to a fixed version for your release line: 3.0.8 or 4.5.3.","what":"GHSA-q2c6-c6pm-g3gh is a code injection vulnerability in handlebars, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q2c6-c6pm-g3gh and fix it if it is affected.\n\nWhat it is: GHSA-q2c6-c6pm-g3gh is a code injection vulnerability in handlebars, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q2c6-c6pm-g3gh in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- handlebars (npm): affected all versions; fixed in 3.0.8\n- handlebars (npm): affected all versions; fixed in 3.0.8\n- handlebars (npm): affected from 4.0.0; fixed in 4.5.3\n- handlebars (npm): affected from 4.0.0; fixed in 4.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q2c6-c6pm-g3gh/ (Markdown: https://insights.sbomify.com/GHSA-q2c6-c6pm-g3gh/index.md)","id":"GHSA-q2c6-c6pm-g3gh","markdown":"https://insights.sbomify.com/GHSA-q2c6-c6pm-g3gh/index.md","name":"GHSA-q2c6-c6pm-g3gh","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript templating library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript by submitting malicious templates to the handlebars library, affecting both server-side and client-side applications.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a [previous issue](https://www.npmjs.com/advisories/1316). This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting).\n\n## Recommendation\n\nUpgrade to version 3.0.8, 4.5.3 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Arbitrary Code Execution in handlebars","id":"GHSA-q2c6-c6pm-g3gh","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["0"],"last_affected":[],"package":"handlebars","purl":null,"source":"GHSA-q2c6-c6pm-g3gh"},{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["0"],"last_affected":[],"package":"handlebars","purl":"pkg:npm/handlebars","source":"GHSA-q2c6-c6pm-g3gh"},{"ecosystem":"npm","fixed":["4.5.3"],"introduced":["4.0.0"],"last_affected":[],"package":"handlebars","purl":null,"source":"GHSA-q2c6-c6pm-g3gh"},{"ecosystem":"npm","fixed":["4.5.3"],"introduced":["4.0.0"],"last_affected":[],"package":"handlebars","purl":"pkg:npm/handlebars","source":"GHSA-q2c6-c6pm-g3gh"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript by submitting malicious templates to the handlebars library, affecting both server-side and client-side applications.","url":"https://insights.sbomify.com/GHSA-q2c6-c6pm-g3gh/"}