{"answers":{"affected":"4 open source packages ship an affected version, including io.apiman:apiman-distro-vertx and io.apiman:apiman-gateway-platforms-vertx.","exploited":"There is no known exploitation of GHSA-q2fj-6h62-59m2 in the wild and no public exploit code.","fix":"Upgrade io.apiman:apiman-distro-vertx to 3.0.0.Final or later.","what":"GHSA-q2fj-6h62-59m2 is an authentication bypass vulnerability in io.apiman:apiman-distro-vertx, published on 30 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q2fj-6h62-59m2 and fix it if it is affected.\n\nWhat it is: GHSA-q2fj-6h62-59m2 is an authentication bypass vulnerability in io.apiman:apiman-distro-vertx, published on 30 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q2fj-6h62-59m2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.apiman:apiman-distro-vertx (Maven): affected all versions; fixed in 3.0.0.Final\n- io.apiman:apiman-distro-vertx (Maven): affected all versions; fixed in 3.0.0.Final\n- io.apiman:apiman-gateway-platforms-vertx (Maven): affected all versions; fixed in 3.0.0.Final\n- io.apiman:apiman-gateway-platforms-vertx (Maven): affected all versions; fixed in 3.0.0.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q2fj-6h62-59m2/ (Markdown: https://insights.sbomify.com/GHSA-q2fj-6h62-59m2/index.md)","id":"GHSA-q2fj-6h62-59m2","markdown":"https://insights.sbomify.com/GHSA-q2fj-6h62-59m2/index.md","name":"GHSA-q2fj-6h62-59m2","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"API Management Gateway","requires_auth":"none","summary":"Unauthenticated remote attackers can access and manipulate cluster data by exploiting a connection caching flaw in the transitive Hazelcast dependency.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nIf you are using the **Apiman Vert.x Gateway** prior to Apiman 3.0.0.Final, a connection caching issue in Hazelcast could allow an unauthenticated, remote attacker to access and manipulate data in the cluster with another authenticated connection's identity.\n\nHazelcast is a transitive dependency of the Apiman Vert.x Gateway.\n\nThe precise risk is difficult to quantify at this juncture as plugins deployed by users may make use of Hazelcast in a different manner to the main Apiman codebase.\n\nIf any of your custom Apiman plugins specify Hazelcast dependencies, you should also bump these versions. \n\nHint: an easy way to track Apiman dependency versions is to use `apiman-parent`.\n\nIf you use the Apiman Tomcat or WildFly Gateway this does not affect you.\n\n### Patches\n\nUpgrade to **Apiman 3.0.0.Final or later**.\n\nIf you are using an older version of Apiman and need to remain on that version, contact to your Apiman support provider for advice/long-term support.\n\n### Workarounds\n\nNone (other than doing your own build).\n\n### References\n\n* https://github.com/advisories/GHSA-c5hg-mr8r-f6jp","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Apiman Vert.x Gateway has Transitive Hazelcast connection caching issue","id":"GHSA-q2fj-6h62-59m2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["3.0.0.Final"],"introduced":["0"],"last_affected":[],"package":"io.apiman:apiman-distro-vertx","purl":null,"source":"GHSA-q2fj-6h62-59m2"},{"ecosystem":"Maven","fixed":["3.0.0.Final"],"introduced":["0"],"last_affected":[],"package":"io.apiman:apiman-distro-vertx","purl":"pkg:maven/io.apiman/apiman-distro-vertx","source":"GHSA-q2fj-6h62-59m2"},{"ecosystem":"Maven","fixed":["3.0.0.Final"],"introduced":["0"],"last_affected":[],"package":"io.apiman:apiman-gateway-platforms-vertx","purl":null,"source":"GHSA-q2fj-6h62-59m2"},{"ecosystem":"Maven","fixed":["3.0.0.Final"],"introduced":["0"],"last_affected":[],"package":"io.apiman:apiman-gateway-platforms-vertx","purl":"pkg:maven/io.apiman/apiman-gateway-platforms-vertx","source":"GHSA-q2fj-6h62-59m2"}],"products":null,"published":"2022-12-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Unauthenticated remote attackers can access and manipulate cluster data by exploiting a connection caching flaw in the transitive Hazelcast dependency.","url":"https://insights.sbomify.com/GHSA-q2fj-6h62-59m2/"}