{"answers":{"affected":"3 open source packages ship an affected version, including gogs.io/gogs.","exploited":"There is no known exploitation of GHSA-q347-cg56-pcq4 in the wild and no public exploit code.","fix":"Upgrade gogs.io/gogs to 0.12.5 or later.","what":"GHSA-q347-cg56-pcq4 is a server-side request forgery vulnerability in gogs.io/gogs, published on 14 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q347-cg56-pcq4 and fix it if it is affected.\n\nWhat it is: GHSA-q347-cg56-pcq4 is a server-side request forgery vulnerability in gogs.io/gogs, published on 14 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q347-cg56-pcq4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gogs.io/gogs (Go): affected all versions; fixed in 0.12.5\n- gogs.io/gogs (Go): affected all versions; fixed in 0.12.5\n- gogs.io/gogs (Go): affected all versions; fixed in 0.12.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q347-cg56-pcq4/ (Markdown: https://insights.sbomify.com/GHSA-q347-cg56-pcq4/index.md)","id":"GHSA-q347-cg56-pcq4","markdown":"https://insights.sbomify.com/GHSA-q347-cg56-pcq4/index.md","name":"GHSA-q347-cg56-pcq4","record":{"aliases":["GO-2022-0377"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Gogs Git server","requires_auth":"low_privilege","summary":"A malicious user can exploit repository migration to discover internal network services, requiring an upgrade to Gogs.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe malicious user is able to discover services in the internal network through repository migration functionality. All installations accepting public traffic are affected.\n\n### Patches\n\nInternal network CIDRs are prohibited to be used as repository migration targets. Users should upgrade to 0.12.5 or the latest 0.13.0+dev.\n\n### Workarounds\n\nRun Gogs in its own private network.\n\n### References\n\nhttps://www.huntr.dev/bounties/327797d7-ae41-498f-9bff-cc0bf98cf531/\n\n### For more information\n\nIf you have any questions or comments about this advisory, please post on #6754.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"SSRF in repository migration","id":"GHSA-q347-cg56-pcq4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"ssrf","year":"2022"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":null,"source":"GHSA-q347-cg56-pcq4"},{"ecosystem":"Go","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GHSA-q347-cg56-pcq4"},{"ecosystem":"Go","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GO-2022-0377"}],"products":null,"published":"2022-03-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious user can exploit repository migration to discover internal network services, requiring an upgrade to Gogs.","url":"https://insights.sbomify.com/GHSA-q347-cg56-pcq4/"}