{"answers":{"affected":"4 open source packages ship an affected version, including wintercms/winter.","exploited":"There is no known exploitation of GHSA-q37h-jhf3-85cj in the wild and no public exploit code.","fix":"Upgrade wintercms/winter to a fixed version for your release line: 1.0.475 or 1.1.9.","what":"GHSA-q37h-jhf3-85cj is a vulnerability in wintercms/winter, published on 15 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q37h-jhf3-85cj and fix it if it is affected.\n\nWhat it is: GHSA-q37h-jhf3-85cj is a vulnerability in wintercms/winter, published on 15 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q37h-jhf3-85cj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wintercms/winter (Packagist): affected all versions; fixed in 1.0.475\n- wintercms/winter (Packagist): affected all versions; fixed in 1.0.475\n- wintercms/winter (Packagist): affected from 1.1.0; fixed in 1.1.9\n- wintercms/winter (Packagist): affected from 1.1.0; fixed in 1.1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q37h-jhf3-85cj/ (Markdown: https://insights.sbomify.com/GHSA-q37h-jhf3-85cj/index.md)","id":"GHSA-q37h-jhf3-85cj","markdown":"https://insights.sbomify.com/GHSA-q37h-jhf3-85cj/index.md","name":"GHSA-q37h-jhf3-85cj","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Winter CMS","requires_auth":"high_privilege","summary":"Privileged users can bypass Safe Mode to modify PHP code in theme templates, enabling arbitrary code execution.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nAuthenticated users with permissions to create or modify theme template objects through the backend \"CMS\" editor can exploit this vulnerability to bypass the `cms.enableSafeMode` security feature if enabled (disables modification of PHP code through the web interface when enabled).\n\nThis is only an issue for Winter CMS instances that rely on the Safe Mode security feature to prevent privileged users from modifying the PHP code of CMS theme template objects through the web interface.\n\nCVSS v3.1 Vector: [AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C](https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C\u0026version=3.1)\n\n### Patches\n\nIssue has been fixed in v1.0.475, v1.1.9, \u0026 v1.2. \n\n### Workarounds\n\nApply https://github.com/wintercms/storm/commit/03eb5ce3f2a271670574802b914f7bcaf07663c1 manually if unable to upgrade to v1.0.475, v1.1.9, or v1.2.0.\n\n### References\n\nSee https://github.com/octobercms/october/security/advisories/GHSA-79jw-2f46-wv22/.\n\nCredit to [David Miller](https://github.com/cydave) for reporting the issue.\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Email us at [hello@wintercms.com](mailto:hello@wintercms.com)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Bypass of CMS Safe Mode Security Feature","id":"GHSA-q37h-jhf3-85cj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.0.475"],"introduced":["0"],"last_affected":[],"package":"wintercms/winter","purl":null,"source":"GHSA-q37h-jhf3-85cj"},{"ecosystem":"Packagist","fixed":["1.0.475"],"introduced":["0"],"last_affected":[],"package":"wintercms/winter","purl":"pkg:composer/wintercms/winter","source":"GHSA-q37h-jhf3-85cj"},{"ecosystem":"Packagist","fixed":["1.1.9"],"introduced":["1.1.0"],"last_affected":[],"package":"wintercms/winter","purl":null,"source":"GHSA-q37h-jhf3-85cj"},{"ecosystem":"Packagist","fixed":["1.1.9"],"introduced":["1.1.0"],"last_affected":[],"package":"wintercms/winter","purl":"pkg:composer/wintercms/winter","source":"GHSA-q37h-jhf3-85cj"}],"products":null,"published":"2022-07-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Privileged users can bypass Safe Mode to modify PHP code in theme templates, enabling arbitrary code execution.","url":"https://insights.sbomify.com/GHSA-q37h-jhf3-85cj/"}