{"answers":{"affected":"2 open source packages ship an affected version, including Umbraco.AI.","exploited":"There is no known exploitation of GHSA-q3v2-xj35-9grx in the wild and no public exploit code.","fix":"Upgrade Umbraco.AI to 1.14.0 or later.","what":"GHSA-q3v2-xj35-9grx is a vulnerability in Umbraco.AI, published on 14 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q3v2-xj35-9grx and fix it if it is affected.\n\nWhat it is: GHSA-q3v2-xj35-9grx is a vulnerability in Umbraco.AI, published on 14 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q3v2-xj35-9grx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Umbraco.AI (NuGet): affected all versions; fixed in 1.14.0\n- Umbraco.AI (NuGet): affected all versions; fixed in 1.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q3v2-xj35-9grx/ (Markdown: https://insights.sbomify.com/GHSA-q3v2-xj35-9grx/index.md)","id":"GHSA-q3v2-xj35-9grx","markdown":"https://insights.sbomify.com/GHSA-q3v2-xj35-9grx/index.md","name":"GHSA-q3v2-xj35-9grx","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Umbraco AI plugin","requires_auth":"high_privilege","summary":"Elevated users can disclose sensitive configuration values, including secrets, in Umbraco.AI under specific custom provider configurations.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nUnder certain configurations, a user with elevated privileges may be able to cause sensitive application configuration values, potentially including secret material such as credentials, to be disclosed. Successful exploitation could expose confidential information and, depending on what the affected installation stores in configuration, enable further compromise. Exploitation requires access to the AI section of the backoffice and a specific custom AI provider, which limits real-world exposure.\n\n### Patches\nPatched in 1.14.0\n\n### Workarounds\nSince the patch is a breaking change and requires a version jump, it is not recommended to try and implement a workaround.\n\n### Resources\n* Announcement Blog Post: https://umbraco.com/blog/security-advisory-june-4-2026-security-patch-for-umbracoai-is-now-available/","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Umbraco.AI discloses sensitive application configuration values","id":"GHSA-q3v2-xj35-9grx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["1.14.0"],"introduced":["0"],"last_affected":[],"package":"Umbraco.AI","purl":null,"source":"GHSA-q3v2-xj35-9grx"},{"ecosystem":"NuGet","fixed":["1.14.0"],"introduced":["0"],"last_affected":[],"package":"Umbraco.AI","purl":"pkg:nuget/Umbraco.AI","source":"GHSA-q3v2-xj35-9grx"}],"products":null,"published":"2026-07-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Elevated users can disclose sensitive configuration values, including secrets, in Umbraco.AI under specific custom provider configurations.","url":"https://insights.sbomify.com/GHSA-q3v2-xj35-9grx/"}