# GHSA-q42p-pg8m-cqh6: Prototype Pollution in handlebars


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Jun 2019

## What is GHSA-q42p-pg8m-cqh6?

GHSA-q42p-pg8m-cqh6 is a vulnerability in handlebars, published on 5 Jun 2019. 

### Official description

Versions of `handlebars` prior to 4.0.14 are vulnerable to Prototype Pollution. Templates may alter an Objects' prototype, thus allowing an attacker to execute arbitrary code on the server.

## Recommendation

For handlebars 4.1.x upgrade to 4.1.2 or later.
For handlebars 4.0.x upgrade to 4.0.14 or later.

## Which versions are affected by GHSA-q42p-pg8m-cqh6?

6 open source packages ship an affected version, including handlebars.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handlebars` | npm | All versions | 3.0.7 |
| `handlebars` | npm | All versions | 3.0.7 |
| `handlebars` | npm | From 4.0.0 | 4.0.14 |
| `handlebars` | npm | From 4.0.0 | 4.0.14 |
| `handlebars` | npm | From 4.1.0 | 4.1.2 |
| `handlebars` | npm | From 4.1.0 | 4.1.2 |

## How do I fix GHSA-q42p-pg8m-cqh6?

Upgrade handlebars to a fixed version for your release line: 3.0.7, 4.0.14 or 4.1.2.

## Is GHSA-q42p-pg8m-cqh6 being exploited?

There is no known exploitation of GHSA-q42p-pg8m-cqh6 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-q42p-pg8m-cqh6 and fix it if it is affected.

What it is: GHSA-q42p-pg8m-cqh6 is a vulnerability in handlebars, published on 5 Jun 2019. 
Exploitation: There is no known exploitation of GHSA-q42p-pg8m-cqh6 in the wild and no public exploit code.

Affected packages and fixed versions:
- handlebars (npm): affected all versions; fixed in 3.0.7
- handlebars (npm): affected all versions; fixed in 3.0.7
- handlebars (npm): affected from 4.0.0; fixed in 4.0.14
- handlebars (npm): affected from 4.0.0; fixed in 4.0.14
- handlebars (npm): affected from 4.1.0; fixed in 4.1.2
- handlebars (npm): affected from 4.1.0; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-q42p-pg8m-cqh6/ (Markdown: https://insights.sbomify.com/GHSA-q42p-pg8m-cqh6/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-q42p-pg8m-cqh6

---
From sbomify Insights: https://insights.sbomify.com/GHSA-q42p-pg8m-cqh6/
Summaries are generated and may contain mistakes; the official description above is the record.
