{"answers":{"affected":"2 open source packages ship an affected version, including @openzeppelin/contracts-upgradeable.","exploited":"There is no known exploitation of GHSA-q4h9-46xg-m3x9 in the wild and no public exploit code.","fix":"Upgrade @openzeppelin/contracts-upgradeable to 4.3.2 or later.","what":"GHSA-q4h9-46xg-m3x9 is a missing authorization vulnerability in @openzeppelin/contracts-upgradeable, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q4h9-46xg-m3x9 and fix it if it is affected.\n\nWhat it is: GHSA-q4h9-46xg-m3x9 is a missing authorization vulnerability in @openzeppelin/contracts-upgradeable, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q4h9-46xg-m3x9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.3.2\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q4h9-46xg-m3x9/ (Markdown: https://insights.sbomify.com/GHSA-q4h9-46xg-m3x9/index.md)","id":"GHSA-q4h9-46xg-m3x9","markdown":"https://insights.sbomify.com/GHSA-q4h9-46xg-m3x9/index.md","name":"GHSA-q4h9-46xg-m3x9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Solidity smart contract library","requires_auth":"none","summary":"Attackers can exploit uninitialized UUPS implementation contracts to gain unauthorized control or execute code, affecting developers using OpenZeppelin upgradeable contracts.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nUpgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. We will update this advisory with more information soon.\n\n### Patches\n\nA fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`.\n\n### Workarounds\n\nInitialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).\n\n### References\n\nA post-mortem will be published in a few days in the [OpenZeppelin Forum](https://forum.openzeppelin.com/).\n\n### For more information\n\nIf you have any questions or comments about this advisory, or need assistance executing the mitigation, email us at security@openzeppelin.com.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"UUPSUpgradeable vulnerability in @openzeppelin/contracts-upgradeable","id":"GHSA-q4h9-46xg-m3x9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.1.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":null,"source":"GHSA-q4h9-46xg-m3x9"},{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.1.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":"pkg:npm/%40openzeppelin/contracts-upgradeable","source":"GHSA-q4h9-46xg-m3x9"}],"products":null,"published":"2021-09-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit uninitialized UUPS implementation contracts to gain unauthorized control or execute code, affecting developers using OpenZeppelin upgradeable contracts.","url":"https://insights.sbomify.com/GHSA-q4h9-46xg-m3x9/"}