{"answers":{"affected":"2 open source packages ship an affected version, including illuminate/auth.","exploited":"There is no known exploitation of GHSA-q4xf-7fw5-4x8v in the wild and no public exploit code.","fix":"Upgrade illuminate/auth to 4.1.26 or later.","what":"GHSA-q4xf-7fw5-4x8v is an authentication bypass vulnerability in illuminate/auth, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q4xf-7fw5-4x8v and fix it if it is affected.\n\nWhat it is: GHSA-q4xf-7fw5-4x8v is an authentication bypass vulnerability in illuminate/auth, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q4xf-7fw5-4x8v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- illuminate/auth (Packagist): affected from 4.0.0; fixed in 4.1.26\n- illuminate/auth (Packagist): affected from 4.0.0; fixed in 4.1.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q4xf-7fw5-4x8v/ (Markdown: https://insights.sbomify.com/GHSA-q4xf-7fw5-4x8v/index.md)","id":"GHSA-q4xf-7fw5-4x8v","markdown":"https://insights.sbomify.com/GHSA-q4xf-7fw5-4x8v/index.md","name":"GHSA-q4xf-7fw5-4x8v","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel framework","requires_auth":"none","summary":"Attackers can maintain persistent access via hijacked remember-me cookies even after password resets or logouts, requiring an upgrade to invalidate stolen sessions.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Laravel 4.1.26 introduces security improvements for \"remember me\" cookies. Before this update, if a remember cookie was hijacked by another malicious user, the cookie would remain valid for a long period of time, even after the true owner of the account reset their password, logged out, etc.\n\nThis change requires the addition of a new remember_token column to your users (or equivalent) database table. After this change, a fresh token will be assigned to the user each time they login to your application. The token will also be refreshed when the user logs out of the application. The implications of this change are: if a \"remember me\" cookie is hijacked, simply logging out of the application will invalidate the cookie.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Laravel Hijacked authentication cookies vulnerability","id":"GHSA-q4xf-7fw5-4x8v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.1.26"],"introduced":["4.0.0"],"last_affected":[],"package":"illuminate/auth","purl":null,"source":"GHSA-q4xf-7fw5-4x8v"},{"ecosystem":"Packagist","fixed":["4.1.26"],"introduced":["4.0.0"],"last_affected":[],"package":"illuminate/auth","purl":"pkg:composer/illuminate/auth","source":"GHSA-q4xf-7fw5-4x8v"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can maintain persistent access via hijacked remember-me cookies even after password resets or logouts, requiring an upgrade to invalidate stolen sessions.","url":"https://insights.sbomify.com/GHSA-q4xf-7fw5-4x8v/"}