{"answers":{"affected":"2 open source packages ship an affected version, including fiona.","exploited":"There is no known exploitation of GHSA-q5fm-55c2-v6j9 in the wild and no public exploit code.","fix":"Upgrade fiona to 1.10b1 or later.","what":"GHSA-q5fm-55c2-v6j9 is a vulnerability in fiona, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-q5fm-55c2-v6j9 and fix it if it is affected.\n\nWhat it is: GHSA-q5fm-55c2-v6j9 is a vulnerability in fiona, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-q5fm-55c2-v6j9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fiona (PyPI): affected all versions; fixed in 1.10b1\n- fiona (PyPI): affected all versions; fixed in 1.10b1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q5fm-55c2-v6j9/ (Markdown: https://insights.sbomify.com/GHSA-q5fm-55c2-v6j9/index.md)","id":"GHSA-q5fm-55c2-v6j9","markdown":"https://insights.sbomify.com/GHSA-q5fm-55c2-v6j9/index.md","name":"GHSA-q5fm-55c2-v6j9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python geospatial library","requires_auth":"none","summary":"An attacker can trigger a heap-based buffer overflow via a malicious zip file, potentially leading to code execution or denial of service.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nVulnerability scan of fiona shows [CVE-2023-45853](https://nvd.nist.gov/vuln/detail/CVE-2023-45853). The vulnerability is in GDAL, a dependency of fiona.\n\n### Details\nFiona depends on GDAL and GDAL has a port of minizip. MiniZip in zlib through 1.3 has an integer overflow and resultant heap-based buffer overflow in zipOpenNewFileInZip4_64 via a long filename, comment, or extra field. The GDAL project has addressed the CVE in version 3.8.0. See https://lists.osgeo.org/pipermail/gdal-dev/2023-November/057881.html.\n\nThe Fiona version 1.9.6 wheels on PyPI include GDAL version 3.6.4 and thus could be vulnerable. All of the Fiona 1.10 pre-release wheels in PyPI include GDAL version 3.8.4 and are not vulnerable.\n\n### Impact\nSystems which use GDAL versions prior to 3.8.0 to open unchecked zip files, whether in combination with fiona or not, could be susceptible to buffer overflows.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Fiona affected by CVE-2023-45853 related to MiniZip madler-zlib","id":"GHSA-q5fm-55c2-v6j9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"integer_overflow","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.10b1"],"introduced":["0"],"last_affected":[],"package":"fiona","purl":null,"source":"GHSA-q5fm-55c2-v6j9"},{"ecosystem":"PyPI","fixed":["1.10b1"],"introduced":["0"],"last_affected":[],"package":"fiona","purl":"pkg:pypi/fiona","source":"GHSA-q5fm-55c2-v6j9"}],"products":null,"published":"2024-07-16","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can trigger a heap-based buffer overflow via a malicious zip file, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/GHSA-q5fm-55c2-v6j9/"}