# GHSA-q5fm-55c2-v6j9: Fiona affected by CVE-2023-45853 related to MiniZip madler-zlib

> An attacker can trigger a heap-based buffer overflow via a malicious zip file, potentially leading to code execution or denial of service.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2024

## What is GHSA-q5fm-55c2-v6j9?

GHSA-q5fm-55c2-v6j9 is a vulnerability in fiona, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

### Summary
Vulnerability scan of fiona shows [CVE-2023-45853](https://nvd.nist.gov/vuln/detail/CVE-2023-45853). The vulnerability is in GDAL, a dependency of fiona.

### Details
Fiona depends on GDAL and GDAL has a port of minizip. MiniZip in zlib through 1.3 has an integer overflow and resultant heap-based buffer overflow in zipOpenNewFileInZip4_64 via a long filename, comment, or extra field. The GDAL project has addressed the CVE in version 3.8.0. See https://lists.osgeo.org/pipermail/gdal-dev/2023-November/057881.html.

The Fiona version 1.9.6 wheels on PyPI include GDAL version 3.6.4 and thus could be vulnerable. All of the Fiona 1.10 pre-release wheels in PyPI include GDAL version 3.8.4 and are not vulnerable.

### Impact
Systems which use GDAL versions prior to 3.8.0 to open unchecked zip files, whether in combination with fiona or not, could be susceptible to buffer overflows.

## Which versions are affected by GHSA-q5fm-55c2-v6j9?

2 open source packages ship an affected version, including fiona.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fiona` | PyPI | All versions | 1.10b1 |
| `fiona` | PyPI | All versions | 1.10b1 |

## How do I fix GHSA-q5fm-55c2-v6j9?

Upgrade fiona to 1.10b1 or later.

## Is GHSA-q5fm-55c2-v6j9 being exploited?

There is no known exploitation of GHSA-q5fm-55c2-v6j9 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-q5fm-55c2-v6j9 and fix it if it is affected.

What it is: GHSA-q5fm-55c2-v6j9 is a vulnerability in fiona, published on 16 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-q5fm-55c2-v6j9 in the wild and no public exploit code.

Affected packages and fixed versions:
- fiona (PyPI): affected all versions; fixed in 1.10b1
- fiona (PyPI): affected all versions; fixed in 1.10b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-q5fm-55c2-v6j9/ (Markdown: https://insights.sbomify.com/GHSA-q5fm-55c2-v6j9/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-q5fm-55c2-v6j9

---
From sbomify Insights: https://insights.sbomify.com/GHSA-q5fm-55c2-v6j9/
Summaries are generated and may contain mistakes; the official description above is the record.
