# GHSA-q6hv-wcjr-wp8h: Impact Because UPDATE validation is not being applied, it is possible for an actor with access to an instance of the [initializingworksp

> Attackers with virtual workspace access can bypass LogicalCluster initialization checks, potentially skipping security or billing integrations.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2025
- **Also known as:** GO-2025-3985

## What is GHSA-q6hv-wcjr-wp8h?

GHSA-q6hv-wcjr-wp8h is a missing authorization vulnerability in github.com/kcp-dev/kcp, published on 26 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact

Because UPDATE validation is not being applied, it is possible for an actor with access to an instance of the [initializingworkspaces virtual workspace](https://docs.kcp.io/kcp/latest/concepts/workspaces/workspace-initialization/) to run arbitrary patches on the status field of `LogicalCluster` objects while the workspace is initializing.

This allows to add or remove any initializers as well as changing the phase of a `LogicalCluster` (to "Ready" for example).

As this effectively allows to skip certain initializers or the entire initialization phase, potential integrations with external systems such as billing or security could be affected. Their initializers could be skipped by a `WorkspaceType` that adds another initializer and grants permissions to the virtual workspace to a rogue or compromised entity.

_Who is impacted?_

* Impacts other owners of `WorkspaceTypes` with initializers that are inherited by other `WorkspaceTypes`.
* Impacts developers using the `virtual/framework` package to create their own virtualworkspaces if they are using UpdateFuncs in their custom storageWrappers.

### Details

The issue occurs because the [rest.ValidateObjectUpdateFunc](https://github.com/kcp-dev/kcp/blob/cli/v0.28.1/pkg/virtual/framework/forwardingregistry/store.go#L174) is not being called within the DefaultDynamicDelegatedStoreFuncs. As a result, the intended status overwrite protection from initializers never gets called, allowing arbitrary logicalcluster status patches.

### Patches

The problem has been patched in #3599 and is available in kcp 0.28.3 and higher.

### Workarounds

- Further limit access to the `initialize` verb on `WorkspaceType` objects (see [documentation](https://docs.kcp.io/kcp/v0.28/concepts/workspaces/workspace-initialization/#enforcing-permissions-for-initializers) for details).
- Only use trusted `WorkspaceType` objects.

### References

See the pull request (#3599).

## Which versions are affected by GHSA-q6hv-wcjr-wp8h?

3 open source packages ship an affected version, including github.com/kcp-dev/kcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kcp-dev/kcp` | Go | All versions | 0.28.3 |
| `github.com/kcp-dev/kcp` | Go | All versions | 0.28.3 |
| `github.com/kcp-dev/kcp` | Go | All versions | 0.28.3 |

## How do I fix GHSA-q6hv-wcjr-wp8h?

Upgrade github.com/kcp-dev/kcp to 0.28.3 or later.

## Is GHSA-q6hv-wcjr-wp8h being exploited?

There is no known exploitation of GHSA-q6hv-wcjr-wp8h in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-q6hv-wcjr-wp8h and fix it if it is affected.

What it is: GHSA-q6hv-wcjr-wp8h is a missing authorization vulnerability in github.com/kcp-dev/kcp, published on 26 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-q6hv-wcjr-wp8h in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kcp-dev/kcp (Go): affected all versions; fixed in 0.28.3
- github.com/kcp-dev/kcp (Go): affected all versions; fixed in 0.28.3
- github.com/kcp-dev/kcp (Go): affected all versions; fixed in 0.28.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-q6hv-wcjr-wp8h/ (Markdown: https://insights.sbomify.com/GHSA-q6hv-wcjr-wp8h/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-q6hv-wcjr-wp8h

---
From sbomify Insights: https://insights.sbomify.com/GHSA-q6hv-wcjr-wp8h/
Summaries are generated and may contain mistakes; the official description above is the record.
