GHSA-q849-wxrc-vqrp hull.js Code Injection Vulnerability
Not scored
Published
Check this codebase for GHSA-q849-wxrc-vqrp and fix it if it is affected.
What it is: GHSA-q849-wxrc-vqrp is a code injection vulnerability in hull.js, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-q849-wxrc-vqrp in the wild and no public exploit code.
Affected packages and fixed versions:
- hull.js (npm): affected from 0.2.2; fixed in 1.0.10
- hull.js (npm): affected from 0.2.2; fixed in 1.0.10
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/GHSA-q849-wxrc-vqrp/ (Markdown: https://insights.sbomify.com/GHSA-q849-wxrc-vqrp/index.md)
An attacker can execute arbitrary code by passing unsanitized input to the hull function, affecting applications using this JavaScript library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-q849-wxrc-vqrp?
GHSA-q849-wxrc-vqrp is a code injection vulnerability in hull.js, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Versions of the library from 0.2.2 to 1.0.9 are vulnerable to the arbitrary code execution due to unsafe usage of
new Function(...) in the module that handles points format. Applications passing the 3rd parameter to the hull function without sanitising may be impacted. The vulnerability has been fixed in version 1.0.10, please update the library. Check project homepage on GitHub to see how to fetch the latest version: https://github.com/andriiheonia/hull?tab=readme-ov-file#npm-packageWhich versions are affected by GHSA-q849-wxrc-vqrp?
2 open source packages ship an affected version, including hull.js.
| Package | Affected | Fixed in |
|---|---|---|
hull.js npm | From 0.2.2 | 1.0.10 |
hull.js npm | From 0.2.2 | 1.0.10 |
How do I fix GHSA-q849-wxrc-vqrp?
Upgrade hull.js to 1.0.10 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is GHSA-q849-wxrc-vqrp being exploited?
There is no known exploitation of GHSA-q849-wxrc-vqrp in the wild and no public exploit code.