{"answers":{"affected":"2 open source packages ship an affected version, including io.apiman:apiman-manager-api-impl.","exploited":"There is no known exploitation of GHSA-q95j-488q-5q3p in the wild and no public exploit code.","fix":"Upgrade io.apiman:apiman-manager-api-impl to 3.0.0.Final or later.","what":"GHSA-q95j-488q-5q3p is a denial of service vulnerability in io.apiman:apiman-manager-api-impl, published on 9 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-q95j-488q-5q3p and fix it if it is affected.\n\nWhat it is: GHSA-q95j-488q-5q3p is a denial of service vulnerability in io.apiman:apiman-manager-api-impl, published on 9 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-q95j-488q-5q3p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.apiman:apiman-manager-api-impl (Maven): affected all versions; fixed in 3.0.0.Final\n- io.apiman:apiman-manager-api-impl (Maven): affected all versions; fixed in 3.0.0.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q95j-488q-5q3p/ (Markdown: https://insights.sbomify.com/GHSA-q95j-488q-5q3p/index.md)","id":"GHSA-q95j-488q-5q3p","markdown":"https://insights.sbomify.com/GHSA-q95j-488q-5q3p/index.md","name":"GHSA-q95j-488q-5q3p","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"API management server","requires_auth":"low_privilege","summary":"An authenticated attacker can cause a denial of service on the Apiman Manager API by crafting a malicious policy configuration.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nDue to a vulnerability in `jackson-databind \u003c= 2.12.6.0`, an authenticated attacker could craft an Apiman policy configuration which, when saved, may cause a denial of service on the Apiman Manager API.\n\nThis does **not** affect the Apiman Gateway.\n\n### Patches\n\nUpgrade to Apiman 3.0.0.Final or later.\n\nIf you are using an older version of Apiman and need to remain on that version, contact your Apiman [support provider](https://www.apiman.io/support.html) for advice/long-term support.\n\n### Workarounds\n\nIf all users of the Apiman Manager are trusted then you may assess this is low risk, as an account is required to exploit the vulnerability.\n\n### References\n\n* Apiman maintainer and security contact: marc@blackparrotlabs.io\n* https://nvd.nist.gov/vuln/detail/CVE-2020-36518\n* https://github.com/FasterXML/jackson-databind/issues/2816","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Apiman Manager API affected by Jackson denial of service vulnerability","id":"GHSA-q95j-488q-5q3p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["3.0.0.Final"],"introduced":["0"],"last_affected":[],"package":"io.apiman:apiman-manager-api-impl","purl":null,"source":"GHSA-q95j-488q-5q3p"},{"ecosystem":"Maven","fixed":["3.0.0.Final"],"introduced":["0"],"last_affected":[],"package":"io.apiman:apiman-manager-api-impl","purl":"pkg:maven/io.apiman/apiman-manager-api-impl","source":"GHSA-q95j-488q-5q3p"}],"products":null,"published":"2023-01-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An authenticated attacker can cause a denial of service on the Apiman Manager API by crafting a malicious policy configuration.","url":"https://insights.sbomify.com/GHSA-q95j-488q-5q3p/"}