{"answers":{"affected":"2 open source packages ship an affected version, including codeigniter/framework.","exploited":"There is no known exploitation of GHSA-q9j3-4ghj-6h57 in the wild and no public exploit code.","fix":"Upgrade codeigniter/framework to 3.0.3 or later.","what":"GHSA-q9j3-4ghj-6h57 is a cross-site scripting vulnerability in codeigniter/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-q9j3-4ghj-6h57 and fix it if it is affected.\n\nWhat it is: GHSA-q9j3-4ghj-6h57 is a cross-site scripting vulnerability in codeigniter/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-q9j3-4ghj-6h57 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter/framework (Packagist): affected all versions; fixed in 3.0.3\n- codeigniter/framework (Packagist): affected all versions; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-q9j3-4ghj-6h57/ (Markdown: https://insights.sbomify.com/GHSA-q9j3-4ghj-6h57/index.md)","id":"GHSA-q9j3-4ghj-6h57","markdown":"https://insights.sbomify.com/GHSA-q9j3-4ghj-6h57/index.md","name":"GHSA-q9j3-4ghj-6h57","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"The CodeIgniter Framework Security Library failed to properly sanitize input, allowing attackers to bypass XSS protections and execute scripts in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The xss_clean() method in the Security Library of CodeIgniter/Framework, specifically in versions before 3.0.3, exhibited a vulnerability that allowed certain Cross-Site Scripting (XSS) vectors to bypass its intended protection mechanisms.\n\nThe xss_clean() method is designed to sanitize input data by removing potentially malicious content, thus preventing XSS attacks. However, in versions prior to 3.0.3, it was discovered that the method did not adequately mitigate specific XSS vectors, leaving a potential security gap.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Inadequate XSS Prevention in CodeIgniter/Framework Security Library","id":"GHSA-q9j3-4ghj-6h57","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter/framework","purl":null,"source":"GHSA-q9j3-4ghj-6h57"},{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter/framework","purl":"pkg:composer/codeigniter/framework","source":"GHSA-q9j3-4ghj-6h57"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The CodeIgniter Framework Security Library failed to properly sanitize input, allowing attackers to bypass XSS protections and execute scripts in user browsers.","url":"https://insights.sbomify.com/GHSA-q9j3-4ghj-6h57/"}