{"answers":{"affected":"2 open source packages ship an affected version, including c2cciutils.","exploited":"There is no known exploitation of GHSA-qc22-xmq4-qg46 in the wild and no public exploit code.","fix":"Upgrade c2cciutils to 1.1.67 or later.","what":"GHSA-qc22-xmq4-qg46 is a vulnerability in c2cciutils, published on 1 Apr 2026."},"fix_prompt":"Check this codebase for GHSA-qc22-xmq4-qg46 and fix it if it is affected.\n\nWhat it is: GHSA-qc22-xmq4-qg46 is a vulnerability in c2cciutils, published on 1 Apr 2026. \nExploitation: There is no known exploitation of GHSA-qc22-xmq4-qg46 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- c2cciutils (PyPI): affected all versions; fixed in 1.1.67\n- c2cciutils (PyPI): affected all versions; fixed in 1.1.67\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qc22-xmq4-qg46/ (Markdown: https://insights.sbomify.com/GHSA-qc22-xmq4-qg46/index.md)","id":"GHSA-qc22-xmq4-qg46","markdown":"https://insights.sbomify.com/GHSA-qc22-xmq4-qg46/index.md","name":"GHSA-qc22-xmq4-qg46","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"unknown","non_default_config":false,"product_category":"Python utility library","requires_auth":"unknown","summary":"The c2cciutils package pins a vulnerable version of Pygments, exposing users to known security flaws in the dependency.","user_interaction":"unknown","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Pinned vulnerable version of Pygment [CVE-2022-40896](https://nvd.nist.gov/vuln/detail/CVE-2022-40896)","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"c2cciutils affected by CVE-2022-40896","id":"GHSA-qc22-xmq4-qg46","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.1.67"],"introduced":["0"],"last_affected":[],"package":"c2cciutils","purl":null,"source":"GHSA-qc22-xmq4-qg46"},{"ecosystem":"PyPI","fixed":["1.1.67"],"introduced":["0"],"last_affected":[],"package":"c2cciutils","purl":"pkg:pypi/c2cciutils","source":"GHSA-qc22-xmq4-qg46"}],"products":null,"published":"2026-04-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The c2cciutils package pins a vulnerable version of Pygments, exposing users to known security flaws in the dependency.","url":"https://insights.sbomify.com/GHSA-qc22-xmq4-qg46/"}