{"answers":{"affected":"4 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-qf36-fx9f-232x in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to a fixed version for your release line: 1.10.9 or 1.11.6.","what":"GHSA-qf36-fx9f-232x is a SQL injection vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qf36-fx9f-232x and fix it if it is affected.\n\nWhat it is: GHSA-qf36-fx9f-232x is a SQL injection vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qf36-fx9f-232x in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.10.0; fixed in 1.10.9\n- zendframework/zendframework1 (Packagist): affected from 1.10.0; fixed in 1.10.9\n- zendframework/zendframework1 (Packagist): affected from 1.11.0; fixed in 1.11.6\n- zendframework/zendframework1 (Packagist): affected from 1.11.0; fixed in 1.11.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qf36-fx9f-232x/ (Markdown: https://insights.sbomify.com/GHSA-qf36-fx9f-232x/index.md)","id":"GHSA-qf36-fx9f-232x","markdown":"https://insights.sbomify.com/GHSA-qf36-fx9f-232x/index.md","name":"GHSA-qf36-fx9f-232x","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"SQL injection possible in Zend Framework when using non-ASCII-compatible encodings with PDO_MySql, allowing attackers to read or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Developers using non-ASCII-compatible encodings in conjunction with the MySQL PDO driver of PHP may be vulnerable to SQL injection attacks. Developers using ASCII-compatible encodings like UTF8 or latin1 are not affected by this PHP issue, which is described in more detail here:\n\nhttp://bugs.php.net/bug.php?id=47802\nThe PHP Group included a feature in PHP 5.3.6+ that allows any character set information to be passed as part of the DSN in PDO to allow both the database as well as the C-level driver to be aware of which charset is in use which is of special importance when PDO's quoting mechanisms are utilized, which Zend Framework also relies on.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework potential SQL Injection Vector When Using PDO_MySql","id":"GHSA-qf36-fx9f-232x","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.10.9"],"introduced":["1.10.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-qf36-fx9f-232x"},{"ecosystem":"Packagist","fixed":["1.10.9"],"introduced":["1.10.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-qf36-fx9f-232x"},{"ecosystem":"Packagist","fixed":["1.11.6"],"introduced":["1.11.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-qf36-fx9f-232x"},{"ecosystem":"Packagist","fixed":["1.11.6"],"introduced":["1.11.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-qf36-fx9f-232x"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"SQL injection possible in Zend Framework when using non-ASCII-compatible encodings with PDO_MySql, allowing attackers to read or modify database contents.","url":"https://insights.sbomify.com/GHSA-qf36-fx9f-232x/"}