{"answers":{"affected":"1 open source package ship an affected version, including bottlerocket/update-operator.","exploited":"There is no known exploitation of GHSA-qf87-q4gg-cg43 in the wild and no public exploit code.","fix":"Upgrade bottlerocket/update-operator to 1.1.0 or later.","what":"GHSA-qf87-q4gg-cg43 is a vulnerability in bottlerocket/update-operator, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qf87-q4gg-cg43 and fix it if it is affected.\n\nWhat it is: GHSA-qf87-q4gg-cg43 is a vulnerability in bottlerocket/update-operator, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qf87-q4gg-cg43 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bottlerocket/update-operator (crates.io): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qf87-q4gg-cg43/ (Markdown: https://insights.sbomify.com/GHSA-qf87-q4gg-cg43/index.md)","id":"GHSA-qf87-q4gg-cg43","markdown":"https://insights.sbomify.com/GHSA-qf87-q4gg-cg43/index.md","name":"GHSA-qf87-q4gg-cg43","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenSSL library","requires_auth":"none","summary":"Attackers can cause denial of service via crashes in applications using OpenSSL when processing malformed PKCS7 data.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A null pointer in OpenSSL can be dereferenced when signatures are being verified in malformed PKCS7 data. Agents or clients compiled with OpenSSL may experience unexpected crashes. OpenSSL has been removed in bottlerocket/update-operator version 1.1.0 in favor of Rust-based TLS using rustls.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"bottlerocket dependency openssl is vulnerable to dereferenced null pointers","id":"GHSA-qf87-q4gg-cg43","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"null_dereference","year":"2023"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"bottlerocket/update-operator","purl":"pkg:cargo/bottlerocket/update-operator","source":"GHSA-qf87-q4gg-cg43"}],"products":null,"published":"2023-02-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service via crashes in applications using OpenSSL when processing malformed PKCS7 data.","url":"https://insights.sbomify.com/GHSA-qf87-q4gg-cg43/"}