# GHSA-qg7m-mwxm-j3h7: Zend-developer-tools information disclosure vulnerability

> An attacker can access sensitive application introspection data via the web-based toolbar because default entries cannot be disabled.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2024

## What is GHSA-qg7m-mwxm-j3h7?

GHSA-qg7m-mwxm-j3h7 is a vulnerability in zendframework/zend-developer-tools, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package zendframework/zend-developer-tools provides a web-based toolbar for introspecting an application. When updating the package to support PHP 7.3, a change was made that could potentially prevent toolbar entries that are enabled by default from being disabled.

## Which versions are affected by GHSA-qg7m-mwxm-j3h7?

2 open source packages ship an affected version, including zendframework/zend-developer-tools.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zend-developer-tools` | Packagist | From 1.2.2 | 1.2.3 |
| `zendframework/zend-developer-tools` | Packagist | From 1.2.2 | 1.2.3 |

## How do I fix GHSA-qg7m-mwxm-j3h7?

Upgrade zendframework/zend-developer-tools to 1.2.3 or later.

## Is GHSA-qg7m-mwxm-j3h7 being exploited?

There is no known exploitation of GHSA-qg7m-mwxm-j3h7 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-qg7m-mwxm-j3h7 and fix it if it is affected.

What it is: GHSA-qg7m-mwxm-j3h7 is a vulnerability in zendframework/zend-developer-tools, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-qg7m-mwxm-j3h7 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zend-developer-tools (Packagist): affected from 1.2.2; fixed in 1.2.3
- zendframework/zend-developer-tools (Packagist): affected from 1.2.2; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-qg7m-mwxm-j3h7/ (Markdown: https://insights.sbomify.com/GHSA-qg7m-mwxm-j3h7/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-qg7m-mwxm-j3h7

---
From sbomify Insights: https://insights.sbomify.com/GHSA-qg7m-mwxm-j3h7/
Summaries are generated and may contain mistakes; the official description above is the record.
