{"answers":{"affected":"3 open source packages ship an affected version, including github.com/foxcpp/maddy.","exploited":"There is no known exploitation of GHSA-qh54-9vc5-m9fg in the wild and no public exploit code.","fix":"Upgrade github.com/foxcpp/maddy to 0.5.2 or later.","what":"GHSA-qh54-9vc5-m9fg is a vulnerability in github.com/foxcpp/maddy, published on 12 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qh54-9vc5-m9fg and fix it if it is affected.\n\nWhat it is: GHSA-qh54-9vc5-m9fg is a vulnerability in github.com/foxcpp/maddy, published on 12 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qh54-9vc5-m9fg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/foxcpp/maddy (Go): affected from 0.5.0; fixed in 0.5.2\n- github.com/foxcpp/maddy (Go): affected from 0.5.0; fixed in 0.5.2\n- github.com/foxcpp/maddy (Go): affected from 0.5.0; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qh54-9vc5-m9fg/ (Markdown: https://insights.sbomify.com/GHSA-qh54-9vc5-m9fg/index.md)","id":"GHSA-qh54-9vc5-m9fg","markdown":"https://insights.sbomify.com/GHSA-qh54-9vc5-m9fg/index.md","name":"GHSA-qh54-9vc5-m9fg","record":{"aliases":["GO-2022-0378"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Maddy mail server","requires_auth":"none","summary":"Maddy mail server allows weak MD5 hashes in shadow files, enabling potential authentication bypass on outdated systems.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThis vulnerability affects maddy 0.5.1, 0.5.0 users using auth.shadow module\nand an extremely outdated system that still allows MD5 hashes in \n/etc/shadows.\n\n### Patches\n\nPatch is available as part of the 0.5.2 release.\n\n### Workarounds\n\nEnsure MD5 hashes are not present in /etc/shadow.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"MD5 hash support in github.com/foxcpp/maddy","id":"GHSA-qh54-9vc5-m9fg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"weak_cryptography","year":"2021"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.5.2"],"introduced":["0.5.0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":null,"source":"GHSA-qh54-9vc5-m9fg"},{"ecosystem":"Go","fixed":["0.5.2"],"introduced":["0.5.0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":"pkg:golang/github.com/foxcpp/maddy","source":"GHSA-qh54-9vc5-m9fg"},{"ecosystem":"Go","fixed":["0.5.2"],"introduced":["0.5.0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":"pkg:golang/github.com/foxcpp/maddy","source":"GO-2022-0378"}],"products":null,"published":"2021-10-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Maddy mail server allows weak MD5 hashes in shadow files, enabling potential authentication bypass on outdated systems.","url":"https://insights.sbomify.com/GHSA-qh54-9vc5-m9fg/"}