{"answers":{"affected":"6 open source packages ship an affected version, including @metamask/sdk, @metamask/sdk-communication-layer and @metamask/sdk-react.","exploited":"There is no known exploitation of GHSA-qj3p-xc97-xw74 in the wild and no public exploit code.","fix":"Upgrade @metamask/sdk to 0.33.1 or later.","what":"GHSA-qj3p-xc97-xw74 is a vulnerability in @metamask/sdk, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qj3p-xc97-xw74 and fix it if it is affected.\n\nWhat it is: GHSA-qj3p-xc97-xw74 is a vulnerability in @metamask/sdk, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qj3p-xc97-xw74 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @metamask/sdk (npm): affected from 0.16.0; fixed in 0.33.1\n- @metamask/sdk (npm): affected from 0.16.0; fixed in 0.33.1\n- @metamask/sdk-communication-layer (npm): affected from 0.16.0; fixed in 0.33.1\n- @metamask/sdk-communication-layer (npm): affected from 0.16.0; fixed in 0.33.1\n- @metamask/sdk-react (npm): affected from 0.16.0; fixed in 0.33.1\n- @metamask/sdk-react (npm): affected from 0.16.0; fixed in 0.33.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qj3p-xc97-xw74/ (Markdown: https://insights.sbomify.com/GHSA-qj3p-xc97-xw74/index.md)","id":"GHSA-qj3p-xc97-xw74","markdown":"https://insights.sbomify.com/GHSA-qj3p-xc97-xw74/index.md","name":"GHSA-qj3p-xc97-xw74","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"workaround","impacts":["security_bypass","other"],"network_reachable":"yes","non_default_config":false,"product_category":"MetaMask SDK","requires_auth":"none","summary":"Developers using MetaMask SDK may have inadvertently installed a malicious debug package, allowing interference with wallet communications.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Who is affected?\nThis advisory only applies to developers who use MetaMask SDK in the browser and who, on Sept 8th 2025 between 13:00–15:30 UTC, performed one of the following actions and then deployed their application:\n- Installed MetaMask SDK into a project with a lockfile for the first time\n- Installed MetaMask SDK in a project without a lockfile\n- Updated a lockfile to pull in `debug@4.4.2` (e.g., via `npm update` or `yarn upgrade`)\n\n### What happened?\nOn Sept 8th, 2025 (13:00–15:30 UTC), a malicious version of the `debug` package (v4.4.2) was published to npm. The injected code attempts to interfere with dApp-to-wallet communication when executed in a browser context. \n\nWhile MetaMask SDK itself was not directly impacted, projects installing the SDK during this window may have inadvertently pulled in the malicious version of `debug`.\n\n### Mitigation\n- If your application was rebuilt and redeployed after Sept 8th, 2025, 15:30 UTC, the malicious version of debug should no longer be present. Please also verify that your package manager (npm, yarn, pnpm, etc.) is not caching `debug@4.4.2`.\n- If you have not yet deployed since performing one of the actions above, delete your `node_modules` and reinstall dependencies before deploying.\n- If your application was deployed during the attack window and has not been rebuilt since, perform a clean install of dependencies and redeploy to ensure the malicious package is removed.\n\n### Resources\n[GitHub Advisory for debug](https://github.com/advisories/GHSA-8mgj-vmr8-frr6)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"MetaMask SDK indirectly exposed via malicious debug@4.4.2 dependency","id":"GHSA-qj3p-xc97-xw74","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2025"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.33.1"],"introduced":["0.16.0"],"last_affected":[],"package":"@metamask/sdk","purl":null,"source":"GHSA-qj3p-xc97-xw74"},{"ecosystem":"npm","fixed":["0.33.1"],"introduced":["0.16.0"],"last_affected":[],"package":"@metamask/sdk","purl":"pkg:npm/%40metamask/sdk","source":"GHSA-qj3p-xc97-xw74"},{"ecosystem":"npm","fixed":["0.33.1"],"introduced":["0.16.0"],"last_affected":[],"package":"@metamask/sdk-communication-layer","purl":null,"source":"GHSA-qj3p-xc97-xw74"},{"ecosystem":"npm","fixed":["0.33.1"],"introduced":["0.16.0"],"last_affected":[],"package":"@metamask/sdk-communication-layer","purl":"pkg:npm/%40metamask/sdk-communication-layer","source":"GHSA-qj3p-xc97-xw74"},{"ecosystem":"npm","fixed":["0.33.1"],"introduced":["0.16.0"],"last_affected":[],"package":"@metamask/sdk-react","purl":null,"source":"GHSA-qj3p-xc97-xw74"},{"ecosystem":"npm","fixed":["0.33.1"],"introduced":["0.16.0"],"last_affected":[],"package":"@metamask/sdk-react","purl":"pkg:npm/%40metamask/sdk-react","source":"GHSA-qj3p-xc97-xw74"}],"products":null,"published":"2025-09-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Developers using MetaMask SDK may have inadvertently installed a malicious debug package, allowing interference with wallet communications.","url":"https://insights.sbomify.com/GHSA-qj3p-xc97-xw74/"}