# GHSA-qj3p-xc97-xw74: MetaMask SDK indirectly exposed via malicious debug@4.4.2 dependency

> Developers using MetaMask SDK may have inadvertently installed a malicious debug package, allowing interference with wallet communications.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2025

## What is GHSA-qj3p-xc97-xw74?

GHSA-qj3p-xc97-xw74 is a vulnerability in @metamask/sdk, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Who is affected?
This advisory only applies to developers who use MetaMask SDK in the browser and who, on Sept 8th 2025 between 13:00–15:30 UTC, performed one of the following actions and then deployed their application:
- Installed MetaMask SDK into a project with a lockfile for the first time
- Installed MetaMask SDK in a project without a lockfile
- Updated a lockfile to pull in `debug@4.4.2` (e.g., via `npm update` or `yarn upgrade`)

### What happened?
On Sept 8th, 2025 (13:00–15:30 UTC), a malicious version of the `debug` package (v4.4.2) was published to npm. The injected code attempts to interfere with dApp-to-wallet communication when executed in a browser context. 

While MetaMask SDK itself was not directly impacted, projects installing the SDK during this window may have inadvertently pulled in the malicious version of `debug`.

### Mitigation
- If your application was rebuilt and redeployed after Sept 8th, 2025, 15:30 UTC, the malicious version of debug should no longer be present. Please also verify that your package manager (npm, yarn, pnpm, etc.) is not caching `debug@4.4.2`.
- If you have not yet deployed since performing one of the actions above, delete your `node_modules` and reinstall dependencies before deploying.
- If your application was deployed during the attack window and has not been rebuilt since, perform a clean install of dependencies and redeploy to ensure the malicious package is removed.

### Resources
[GitHub Advisory for debug](https://github.com/advisories/GHSA-8mgj-vmr8-frr6)

## Which versions are affected by GHSA-qj3p-xc97-xw74?

6 open source packages ship an affected version, including @metamask/sdk, @metamask/sdk-communication-layer and @metamask/sdk-react.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@metamask/sdk` | npm | From 0.16.0 | 0.33.1 |
| `@metamask/sdk` | npm | From 0.16.0 | 0.33.1 |
| `@metamask/sdk-communication-layer` | npm | From 0.16.0 | 0.33.1 |
| `@metamask/sdk-communication-layer` | npm | From 0.16.0 | 0.33.1 |
| `@metamask/sdk-react` | npm | From 0.16.0 | 0.33.1 |
| `@metamask/sdk-react` | npm | From 0.16.0 | 0.33.1 |

## How do I fix GHSA-qj3p-xc97-xw74?

Upgrade @metamask/sdk to 0.33.1 or later.

## Is GHSA-qj3p-xc97-xw74 being exploited?

There is no known exploitation of GHSA-qj3p-xc97-xw74 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-qj3p-xc97-xw74 and fix it if it is affected.

What it is: GHSA-qj3p-xc97-xw74 is a vulnerability in @metamask/sdk, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-qj3p-xc97-xw74 in the wild and no public exploit code.

Affected packages and fixed versions:
- @metamask/sdk (npm): affected from 0.16.0; fixed in 0.33.1
- @metamask/sdk (npm): affected from 0.16.0; fixed in 0.33.1
- @metamask/sdk-communication-layer (npm): affected from 0.16.0; fixed in 0.33.1
- @metamask/sdk-communication-layer (npm): affected from 0.16.0; fixed in 0.33.1
- @metamask/sdk-react (npm): affected from 0.16.0; fixed in 0.33.1
- @metamask/sdk-react (npm): affected from 0.16.0; fixed in 0.33.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-qj3p-xc97-xw74/ (Markdown: https://insights.sbomify.com/GHSA-qj3p-xc97-xw74/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-qj3p-xc97-xw74

---
From sbomify Insights: https://insights.sbomify.com/GHSA-qj3p-xc97-xw74/
Summaries are generated and may contain mistakes; the official description above is the record.
