# GHSA-qq2p-4282-cfc5: eduMFA: Incorrect InnoDB snapshot isolation possibly allows token reusage

> Attackers can reuse one-time tokens in eduMFA due to database race conditions, bypassing authentication if specific database isolation settings are used.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2026

## What is GHSA-qq2p-4282-cfc5?

GHSA-qq2p-4282-cfc5 is a vulnerability in edumfa, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact

For deployments using MySQL or MariaDB < 11.6.2 (or newer with innodb_snapshot_isolation=off) reusage of token values might be possible due to faulty transaction isolation inside the database. Exploiting this requires racing this transaction.
Affected are all tokentypes whose values are only supposed to be used once, for example TOTP, HOTP and likely also WebAuthN.

#### Affected Combinations:

- MySQL (any version)
- MariaDB with innodb_snapshot_isolation=OFF
  - innodb_snapshot_isolation was introduced in: MariaDB 10.6.18, MariaDB 10.11.8, MariaDB 11.0.6, MariaDB 11.1.5, MariaDB 11.2.4, MariaDB 11.4.2
    with default OFF, can be turned ON as a workaround
  - for MariaDB >= 11.6.2 the default is ON, which is not affected
- Same rules applies for Galera with underlying MariaDB

### Patches
Fixed in version 2.9.1 by locking rows prior to write with SELECT FOR UPDATE.

### Workarounds
Set innodb_snapshot_isolation to ON (default in MariaDB >= 11.6.2, e.g packaged in Debian 13).

### Resources
https://mariadb.com/resources/blog/isolation-level-violation-testing-and-debugging-in-mariadb/

## Which versions are affected by GHSA-qq2p-4282-cfc5?

2 open source packages ship an affected version, including edumfa.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edumfa` | PyPI | All versions | 2.9.1 |
| `edumfa` | PyPI | All versions | 2.9.1 |

## How do I fix GHSA-qq2p-4282-cfc5?

Upgrade edumfa to 2.9.1 or later.

## Is GHSA-qq2p-4282-cfc5 being exploited?

There is no known exploitation of GHSA-qq2p-4282-cfc5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-qq2p-4282-cfc5 and fix it if it is affected.

What it is: GHSA-qq2p-4282-cfc5 is a vulnerability in edumfa, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-qq2p-4282-cfc5 in the wild and no public exploit code.

Affected packages and fixed versions:
- edumfa (PyPI): affected all versions; fixed in 2.9.1
- edumfa (PyPI): affected all versions; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-qq2p-4282-cfc5/ (Markdown: https://insights.sbomify.com/GHSA-qq2p-4282-cfc5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-qq2p-4282-cfc5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-qq2p-4282-cfc5/
Summaries are generated and may contain mistakes; the official description above is the record.
