GHSA-qq6h-5g6j-q3cm sweetalert2 v11.4.9 and above contains hidden functionality
Malicious maintainer introduced hidden audio/video output functionality in this JavaScript library, requiring users to downgrade to a safe version.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-qq6h-5g6j-q3cm?
GHSA-qq6h-5g6j-q3cm is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
sweetalert2 versions 11.4.9 and above are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 11.0.0 - 11.4.8.
Workaround
Use a version 11.0.0 - 11.4.8 of the package until the maintainer releases a fix.
Which versions are affected by GHSA-qq6h-5g6j-q3cm?
2 open source packages ship an affected version, including sweetalert2.
| Package | Affected | Fixed in |
|---|---|---|
sweetalert2 npm | From 11.4.9 | 11.22.4 |
sweetalert2 npm | From 11.4.9 | 11.22.4 |
How do I fix GHSA-qq6h-5g6j-q3cm?
Upgrade sweetalert2 to 11.22.4 or later.
Is GHSA-qq6h-5g6j-q3cm being exploited?
There is no known exploitation of GHSA-qq6h-5g6j-q3cm in the wild and no public exploit code.