# GHSA-qq6h-5g6j-q3cm: sweetalert2 v11.4.9 and above contains hidden functionality

> Malicious maintainer introduced hidden audio/video output functionality in this JavaScript library, requiring users to downgrade to a safe version.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2022

## What is GHSA-qq6h-5g6j-q3cm?

GHSA-qq6h-5g6j-q3cm is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`sweetalert2` versions 11.4.9 and above are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 11.0.0 - 11.4.8.

### Workaround
Use a version 11.0.0 - 11.4.8 of the package until the maintainer releases a fix.

## Which versions are affected by GHSA-qq6h-5g6j-q3cm?

2 open source packages ship an affected version, including sweetalert2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sweetalert2` | npm | From 11.4.9 | 11.22.4 |
| `sweetalert2` | npm | From 11.4.9 | 11.22.4 |

## How do I fix GHSA-qq6h-5g6j-q3cm?

Upgrade sweetalert2 to 11.22.4 or later.

## Is GHSA-qq6h-5g6j-q3cm being exploited?

There is no known exploitation of GHSA-qq6h-5g6j-q3cm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-qq6h-5g6j-q3cm and fix it if it is affected.

What it is: GHSA-qq6h-5g6j-q3cm is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-qq6h-5g6j-q3cm in the wild and no public exploit code.

Affected packages and fixed versions:
- sweetalert2 (npm): affected from 11.4.9; fixed in 11.22.4
- sweetalert2 (npm): affected from 11.4.9; fixed in 11.22.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-qq6h-5g6j-q3cm/ (Markdown: https://insights.sbomify.com/GHSA-qq6h-5g6j-q3cm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-qq6h-5g6j-q3cm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-qq6h-5g6j-q3cm/
Summaries are generated and may contain mistakes; the official description above is the record.
