GHSA-qr2g-p6q7-w82m x402 SDK Security Advisory
Facilitators processing Solana payments must upgrade the x402 SDK to mitigate a security vulnerability in outdated versions.
- Exploited in the wild
- Not known
- Login needed
- Not stated
- Attackable
- Over the internet
- Victim action needed
- Not stated
- Fix
- Available
What is GHSA-qr2g-p6q7-w82m?
GHSA-qr2g-p6q7-w82m is a vulnerability in github.com/coinbase/x402/go, published on 7 Mar 2026. It can be exploited over the network.
Official description
Impact
A security vulnerability exists in outdated versions of the x402 SDK.
This vulnerability does not affect users' private keys, smart contracts, or funds.
The issue impacts resource servers accepting payments on Solana when the facilitator is running a vulnerable version of the x402 SDK.
Who Should Take Action
Facilitators that process payments on Solana must upgrade the x402 SDK to the patched versions listed below.
Clients are not required to upgrade.
Resource servers are not required to upgrade unless they operate their own facilitator (self-facilitate).
Patches
Please update to the following package versions:
- Npm: @x402/svm >= 2.6.0
- Pypi: x402 >= 2.3.0
- Go: x402 >= 2.5.0
Which versions are affected by GHSA-qr2g-p6q7-w82m?
7 open source packages ship an affected version, including github.com/coinbase/x402/go, x402 and @x402/svm.
| Package | Affected | Fixed in |
|---|---|---|
github.com/coinbase/x402/go Go | All versions | None |
github.com/coinbase/x402/go Go | All versions | 2.5.0 |
github.com/coinbase/x402/go Go | All versions | 2.5.0 |
x402 PyPI | All versions | 2.3.0 |
x402 PyPI | All versions | 2.3.0 |
@x402/svm npm | All versions | 2.6.0 |
1 more packages
@x402/svm npm | All versions | 2.6.0 |
How do I fix GHSA-qr2g-p6q7-w82m?
Upgrade github.com/coinbase/x402/go to 2.5.0 or later.
Is GHSA-qr2g-p6q7-w82m being exploited?
There is no known exploitation of GHSA-qr2g-p6q7-w82m in the wild and no public exploit code.
Sources
Also known as GO-2026-4647.