{"answers":{"affected":"7 open source packages ship an affected version, including github.com/coinbase/x402/go, x402 and @x402/svm.","exploited":"There is no known exploitation of GHSA-qr2g-p6q7-w82m in the wild and no public exploit code.","fix":"Upgrade github.com/coinbase/x402/go to 2.5.0 or later.","what":"GHSA-qr2g-p6q7-w82m is a vulnerability in github.com/coinbase/x402/go, published on 7 Mar 2026. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-qr2g-p6q7-w82m and fix it if it is affected.\n\nWhat it is: GHSA-qr2g-p6q7-w82m is a vulnerability in github.com/coinbase/x402/go, published on 7 Mar 2026. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-qr2g-p6q7-w82m in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/coinbase/x402/go (Go): affected all versions; no fix listed\n- github.com/coinbase/x402/go (Go): affected all versions; fixed in 2.5.0\n- github.com/coinbase/x402/go (Go): affected all versions; fixed in 2.5.0\n- x402 (PyPI): affected all versions; fixed in 2.3.0\n- x402 (PyPI): affected all versions; fixed in 2.3.0\n- @x402/svm (npm): affected all versions; fixed in 2.6.0\n- @x402/svm (npm): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qr2g-p6q7-w82m/ (Markdown: https://insights.sbomify.com/GHSA-qr2g-p6q7-w82m/index.md)","id":"GHSA-qr2g-p6q7-w82m","markdown":"https://insights.sbomify.com/GHSA-qr2g-p6q7-w82m/index.md","name":"GHSA-qr2g-p6q7-w82m","record":{"aliases":["GO-2026-4647"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"x402 payment SDK","requires_auth":"unknown","summary":"Facilitators processing Solana payments must upgrade the x402 SDK to mitigate a security vulnerability in outdated versions.","user_interaction":"unknown","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nA security vulnerability exists in outdated versions of the x402 SDK.\n\nThis vulnerability does not affect users' private keys, smart contracts, or funds.\n\nThe issue impacts resource servers accepting payments on Solana when the facilitator is running a vulnerable version of the x402 SDK.\n\n### Who Should Take Action\n\nFacilitators that process payments on Solana must upgrade the x402 SDK to the patched versions listed below.\n\nClients are not required to upgrade.\n\nResource servers are not required to upgrade unless they operate their own facilitator (self-facilitate).\n\n### Patches\n\nPlease update to the following package versions:\n* Npm: @x402/svm \u003e= 2.6.0\n* Pypi: x402 \u003e= 2.3.0\n* Go: x402 \u003e= 2.5.0","ecosystems":["Go","PyPI","npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"x402 SDK Security Advisory","id":"GHSA-qr2g-p6q7-w82m","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"other","year":"2026"},"n_packages":7,"n_references":null,"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/coinbase/x402/go","purl":"pkg:golang/github.com/coinbase/x402/go","source":"GO-2026-4647"},{"ecosystem":"Go","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/coinbase/x402/go","purl":null,"source":"GHSA-qr2g-p6q7-w82m"},{"ecosystem":"Go","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/coinbase/x402/go","purl":"pkg:golang/github.com/coinbase/x402/go","source":"GHSA-qr2g-p6q7-w82m"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"x402","purl":null,"source":"GHSA-qr2g-p6q7-w82m"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"x402","purl":"pkg:pypi/x402","source":"GHSA-qr2g-p6q7-w82m"},{"ecosystem":"npm","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"@x402/svm","purl":null,"source":"GHSA-qr2g-p6q7-w82m"},{"ecosystem":"npm","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"@x402/svm","purl":"pkg:npm/%40x402/svm","source":"GHSA-qr2g-p6q7-w82m"}],"products":null,"published":"2026-03-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Facilitators processing Solana payments must upgrade the x402 SDK to mitigate a security vulnerability in outdated versions.","url":"https://insights.sbomify.com/GHSA-qr2g-p6q7-w82m/"}