{"answers":{"affected":"2 open source packages ship an affected version, including opencv-python.","exploited":"There is no known exploitation of GHSA-qr4w-53vh-m672 in the wild and no public exploit code.","fix":"Upgrade opencv-python to 4.8.1.78 or later.","what":"GHSA-qr4w-53vh-m672 is a memory corruption vulnerability in opencv-python, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-qr4w-53vh-m672 and fix it if it is affected.\n\nWhat it is: GHSA-qr4w-53vh-m672 is a memory corruption vulnerability in opencv-python, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-qr4w-53vh-m672 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opencv-python (PyPI): affected all versions; fixed in 4.8.1.78\n- opencv-python (PyPI): affected all versions; fixed in 4.8.1.78\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qr4w-53vh-m672/ (Markdown: https://insights.sbomify.com/GHSA-qr4w-53vh-m672/index.md)","id":"GHSA-qr4w-53vh-m672","markdown":"https://insights.sbomify.com/GHSA-qr4w-53vh-m672/index.md","name":"GHSA-qr4w-53vh-m672","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python computer vision library","requires_auth":"none","summary":"Attackers can execute arbitrary code or cause denial of service by tricking users into processing malicious WebP images via the vulnerable bundled libwebp library.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"opencv-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. opencv-python v4.8.1.78 upgrades the bundled libwebp binary to v1.3.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"opencv-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863","id":"GHSA-qr4w-53vh-m672","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["4.8.1.78"],"introduced":["0"],"last_affected":[],"package":"opencv-python","purl":null,"source":"GHSA-qr4w-53vh-m672"},{"ecosystem":"PyPI","fixed":["4.8.1.78"],"introduced":["0"],"last_affected":[],"package":"opencv-python","purl":"pkg:pypi/opencv-python","source":"GHSA-qr4w-53vh-m672"}],"products":null,"published":"2024-08-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code or cause denial of service by tricking users into processing malicious WebP images via the vulnerable bundled libwebp library.","url":"https://insights.sbomify.com/GHSA-qr4w-53vh-m672/"}