GHSA-qr8r-m495-7hc4 Validation of `VoteExtensionsEnableHeight` can cause chain halt in Go package github.com/cometbft/cometbft
A validation flaw in CometBFT allows a governance proposal to trigger a panic, halting the blockchain network for all nodes.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-qr8r-m495-7hc4?
GHSA-qr8r-m495-7hc4 is a denial of service vulnerability in github.com/cometbft/cometbft, published on 19 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Summary
A vulnerability in CometBFT’s validation logic for VoteExtensionsEnableHeight can result in a chain halt when triggered through a governance parameter change proposal on an ABCI2 Application Chain. If a parameter change proposal including a VoteExtensionsEnableHeight modification is passed, nodes running the affected versions may panic, halting the network.
The CometBFT team addressed this issue by improving validation logic for the VoteExtensionsEnableHeight to correctly handle governance proposals addressing this parameter.
Next Steps for Impacted Parties
If you are a chain developer with an active network running on CometBFT v. 0.38.x, we recommend updating your chain application to v0.38.3 or later of CometBFT to patch this issue.
This issue can be resolved with a “soft patch” to an active network, i.e. nodes can be patched and restarted at different times without the need for a coordinated upgrade that halts a chain. If this patching methodology is used, the risk of a network halt triggered by this issue is mitigated once more than 66.7% of voting power on the network has applied the update, which provides protection from exploitation while on-chain governance processes for software upgrades take place. Once all validator nodes operating a network have been updated, the risk of a network halt due to this issue will be fully resolved.
For more information about CometBFT, see https://docs.cometbft.com/.
This issue was found by Dongsam (@b_harvest) who reported it to the Cosmos Bug Bounty Program on HackerOne on January 15, 2024. If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.
Which versions are affected by GHSA-qr8r-m495-7hc4?
3 open source packages ship an affected version, including github.com/cometbft/cometbft.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cometbft/cometbft Go | From 0.38.0 | 0.38.3 |
github.com/cometbft/cometbft Go | From 0.38.0 | 0.38.3 |
github.com/cometbft/cometbft Go | From 0.38.0 | 0.38.3 |
How do I fix GHSA-qr8r-m495-7hc4?
Upgrade github.com/cometbft/cometbft to 0.38.3 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-qr8r-m495-7hc4 being exploited?
There is no known exploitation of GHSA-qr8r-m495-7hc4 in the wild and no public exploit code.
Sources
Also known as GO-2024-2471.