{"answers":{"affected":"3 open source packages ship an affected version, including github.com/cometbft/cometbft.","exploited":"There is no known exploitation of GHSA-qr8r-m495-7hc4 in the wild and no public exploit code.","fix":"Upgrade github.com/cometbft/cometbft to 0.38.3 or later.","what":"GHSA-qr8r-m495-7hc4 is a denial of service vulnerability in github.com/cometbft/cometbft, published on 19 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qr8r-m495-7hc4 and fix it if it is affected.\n\nWhat it is: GHSA-qr8r-m495-7hc4 is a denial of service vulnerability in github.com/cometbft/cometbft, published on 19 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qr8r-m495-7hc4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/cometbft/cometbft (Go): affected from 0.38.0; fixed in 0.38.3\n- github.com/cometbft/cometbft (Go): affected from 0.38.0; fixed in 0.38.3\n- github.com/cometbft/cometbft (Go): affected from 0.38.0; fixed in 0.38.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qr8r-m495-7hc4/ (Markdown: https://insights.sbomify.com/GHSA-qr8r-m495-7hc4/index.md)","id":"GHSA-qr8r-m495-7hc4","markdown":"https://insights.sbomify.com/GHSA-qr8r-m495-7hc4/index.md","name":"GHSA-qr8r-m495-7hc4","record":{"aliases":["GO-2024-2471"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CometBFT consensus library","requires_auth":"high_privilege","summary":"A validation flaw in CometBFT allows a governance proposal to trigger a panic, halting the blockchain network for all nodes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Summary\n\nA vulnerability in CometBFT’s validation logic for `VoteExtensionsEnableHeight` can result in a chain halt when triggered through a governance parameter change proposal on an ABCI2 Application Chain. If a parameter change proposal including a `VoteExtensionsEnableHeight` modification is passed, nodes running the affected versions may panic, halting the network.\n\nThe CometBFT team addressed this issue by improving validation logic for the `VoteExtensionsEnableHeight` to correctly handle governance proposals addressing this parameter.\n\n## Next Steps for Impacted Parties\n\nIf you are a chain developer with an active network running on CometBFT v. 0.38.x, we recommend updating your chain application to v0.38.3 or later of CometBFT to patch this issue. \n\nThis issue can be resolved with a “soft patch” to an active network, i.e. nodes can be patched and restarted at different times without the need for a coordinated upgrade that halts a chain. If this patching methodology is used, the risk of a network halt triggered by this issue is mitigated once more than 66.7% of voting power on the network has applied the update, which provides protection from exploitation while on-chain governance processes for software upgrades take place. Once all validator nodes operating a network have been updated, the risk of a network halt due to this issue will be fully resolved. \n\nFor more information about CometBFT, see https://docs.cometbft.com/. \n\nThis issue was found by Dongsam ([@b_harvest](https://twitter.com/b__harvest?lang=en)) who reported it to the Cosmos Bug Bounty Program on HackerOne on January 15, 2024. If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Validation of `VoteExtensionsEnableHeight` can cause chain halt in Go package github.com/cometbft/cometbft","id":"GHSA-qr8r-m495-7hc4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.38.3"],"introduced":["0.38.0"],"last_affected":[],"package":"github.com/cometbft/cometbft","purl":null,"source":"GHSA-qr8r-m495-7hc4"},{"ecosystem":"Go","fixed":["0.38.3"],"introduced":["0.38.0"],"last_affected":[],"package":"github.com/cometbft/cometbft","purl":"pkg:golang/github.com/cometbft/cometbft","source":"GHSA-qr8r-m495-7hc4"},{"ecosystem":"Go","fixed":["0.38.3"],"introduced":["0.38.0"],"last_affected":[],"package":"github.com/cometbft/cometbft","purl":"pkg:golang/github.com/cometbft/cometbft","source":"GO-2024-2471"}],"products":null,"published":"2024-01-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A validation flaw in CometBFT allows a governance proposal to trigger a panic, halting the blockchain network for all nodes.","url":"https://insights.sbomify.com/GHSA-qr8r-m495-7hc4/"}