GHSA-qrmm-w4v4-q7f8 Unauthorized access through URL manipulation
Attackers can gain unauthorized access to system information via URL manipulation in docassemble, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-qrmm-w4v4-q7f8?
GHSA-qrmm-w4v4-q7f8 is an authentication bypass vulnerability in docassemble, published on 6 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation.
Patches
The vulnerability has been patched in version 1.2.65 of the master branch, version 1.1.113 of the 1.1.x series, and version 1.0.12 of the stable branch. The Docker image on docker.io has been patched.
Workarounds
If upgrading is not possible, manually apply the changes of https://github.com/jhpyle/docassemble/commit/e3dbf6ce054b3c0310996f0657289f5eed0a73fe and restart the server (e.g., by pressing Save on the Configuration screen).
Credit
The vulnerability was discovered by Jim Platania of Seiso LLC (@jimmio).
For more information
If you have any questions or comments about this advisory:
- Open an issue in docassemble
- Join the Slack channel
- Email us at [email protected]
Which versions are affected by GHSA-qrmm-w4v4-q7f8?
2 open source packages ship an affected version, including docassemble.
| Package | Affected | Fixed in |
|---|---|---|
docassemble PyPI | All versions | 1.2.65 |
docassemble PyPI | All versions | 1.2.65 |
How do I fix GHSA-qrmm-w4v4-q7f8?
Upgrade docassemble to 1.2.65 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is GHSA-qrmm-w4v4-q7f8 being exploited?
There is no known exploitation of GHSA-qrmm-w4v4-q7f8 in the wild and no public exploit code.