{"answers":{"affected":"2 open source packages ship an affected version, including docassemble.","exploited":"There is no known exploitation of GHSA-qrmm-w4v4-q7f8 in the wild and no public exploit code.","fix":"Upgrade docassemble to 1.2.65 or later.","what":"GHSA-qrmm-w4v4-q7f8 is an authentication bypass vulnerability in docassemble, published on 6 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qrmm-w4v4-q7f8 and fix it if it is affected.\n\nWhat it is: GHSA-qrmm-w4v4-q7f8 is an authentication bypass vulnerability in docassemble, published on 6 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qrmm-w4v4-q7f8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- docassemble (PyPI): affected all versions; fixed in 1.2.65\n- docassemble (PyPI): affected all versions; fixed in 1.2.65\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qrmm-w4v4-q7f8/ (Markdown: https://insights.sbomify.com/GHSA-qrmm-w4v4-q7f8/index.md)","id":"GHSA-qrmm-w4v4-q7f8","markdown":"https://insights.sbomify.com/GHSA-qrmm-w4v4-q7f8/index.md","name":"GHSA-qrmm-w4v4-q7f8","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"docassemble legal software","requires_auth":"none","summary":"Attackers can gain unauthorized access to system information via URL manipulation in docassemble, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThe vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation.\n\n### Patches\nThe vulnerability has been patched in version 1.2.65 of the `master` branch, version 1.1.113 of the 1.1.x series, and version 1.0.12 of the `stable` branch. The Docker image on docker.io has been patched.\n\n### Workarounds\nIf upgrading is not possible, manually apply the changes of https://github.com/jhpyle/docassemble/commit/e3dbf6ce054b3c0310996f0657289f5eed0a73fe and restart the server (e.g., by pressing Save on the Configuration screen).\n\n### Credit\nThe vulnerability was discovered by Jim Platania of Seiso LLC (@jimmio).\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [docassemble](https://github.com/jhpyle/docassemble/issues)\n* Join the [Slack channel](https://join.slack.com/t/docassemble/shared_invite/zt-ohrn8y9z-_Fb3RAl~JPBU6Km7odBPfQ)\n* Email us at [jhpyle@gmail.com](mailto:jhpyle@gmail.com)","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Unauthorized access through URL manipulation","id":"GHSA-qrmm-w4v4-q7f8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.2.65"],"introduced":["0"],"last_affected":[],"package":"docassemble","purl":null,"source":"GHSA-qrmm-w4v4-q7f8"},{"ecosystem":"PyPI","fixed":["1.2.65"],"introduced":["0"],"last_affected":[],"package":"docassemble","purl":"pkg:pypi/docassemble","source":"GHSA-qrmm-w4v4-q7f8"}],"products":null,"published":"2021-05-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can gain unauthorized access to system information via URL manipulation in docassemble, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/GHSA-qrmm-w4v4-q7f8/"}