# GHSA-qrmm-w4v4-q7f8: Unauthorized access through URL manipulation

> Attackers can gain unauthorized access to system information via URL manipulation in docassemble, requiring an upgrade to patched versions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2021

## What is GHSA-qrmm-w4v4-q7f8?

GHSA-qrmm-w4v4-q7f8 is an authentication bypass vulnerability in docassemble, published on 6 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact
The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation.

### Patches
The vulnerability has been patched in version 1.2.65 of the `master` branch, version 1.1.113 of the 1.1.x series, and version 1.0.12 of the `stable` branch. The Docker image on docker.io has been patched.

### Workarounds
If upgrading is not possible, manually apply the changes of https://github.com/jhpyle/docassemble/commit/e3dbf6ce054b3c0310996f0657289f5eed0a73fe and restart the server (e.g., by pressing Save on the Configuration screen).

### Credit
The vulnerability was discovered by Jim Platania of Seiso LLC (@jimmio).

### For more information
If you have any questions or comments about this advisory:
* Open an issue in [docassemble](https://github.com/jhpyle/docassemble/issues)
* Join the [Slack channel](https://join.slack.com/t/docassemble/shared_invite/zt-ohrn8y9z-_Fb3RAl~JPBU6Km7odBPfQ)
* Email us at [jhpyle@gmail.com](mailto:jhpyle@gmail.com)

## Which versions are affected by GHSA-qrmm-w4v4-q7f8?

2 open source packages ship an affected version, including docassemble.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docassemble` | PyPI | All versions | 1.2.65 |
| `docassemble` | PyPI | All versions | 1.2.65 |

## How do I fix GHSA-qrmm-w4v4-q7f8?

Upgrade docassemble to 1.2.65 or later.

## Is GHSA-qrmm-w4v4-q7f8 being exploited?

There is no known exploitation of GHSA-qrmm-w4v4-q7f8 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-qrmm-w4v4-q7f8 and fix it if it is affected.

What it is: GHSA-qrmm-w4v4-q7f8 is an authentication bypass vulnerability in docassemble, published on 6 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-qrmm-w4v4-q7f8 in the wild and no public exploit code.

Affected packages and fixed versions:
- docassemble (PyPI): affected all versions; fixed in 1.2.65
- docassemble (PyPI): affected all versions; fixed in 1.2.65

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-qrmm-w4v4-q7f8/ (Markdown: https://insights.sbomify.com/GHSA-qrmm-w4v4-q7f8/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-qrmm-w4v4-q7f8

---
From sbomify Insights: https://insights.sbomify.com/GHSA-qrmm-w4v4-q7f8/
Summaries are generated and may contain mistakes; the official description above is the record.
