{"answers":{"affected":"4 open source packages ship an affected version, including shopware/core and shopware/platform.","exploited":"There is no known exploitation of GHSA-qvc5-cfrr-384v in the wild and no public exploit code.","fix":"Upgrade shopware/core to 6.3.1.1 or later.","what":"GHSA-qvc5-cfrr-384v is a code injection vulnerability in shopware/core, published on 23 Sep 2020. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-qvc5-cfrr-384v and fix it if it is affected.\n\nWhat it is: GHSA-qvc5-cfrr-384v is a code injection vulnerability in shopware/core, published on 23 Sep 2020. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-qvc5-cfrr-384v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/core (Packagist): affected all versions; fixed in 6.3.1.1\n- shopware/core (Packagist): affected all versions; fixed in 6.3.1.1\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.1.1\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qvc5-cfrr-384v/ (Markdown: https://insights.sbomify.com/GHSA-qvc5-cfrr-384v/index.md)","id":"GHSA-qvc5-cfrr-384v","markdown":"https://insights.sbomify.com/GHSA-qvc5-cfrr-384v/index.md","name":"GHSA-qvc5-cfrr-384v","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"unknown","summary":"Remote code execution vulnerability in a third-party library used by Shopware allows attackers to execute arbitrary code.","user_interaction":"unknown","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nRCE in Third Party Library\n\n### Patches\nWe recommend to update to the current version 6.3.1.1. You can get the update to 6.3.1.1 regularly via the Auto-Updater or directly via the download overview. \n\nFor older versions you can use the Security Plugin:\nhttps://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659\n\n### References\nhttps://docs.shopware.com/en/shopware-6-en/security-updates/security-update-09-2020","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"RCE in Third Party Library in Shopware","id":"GHSA-qvc5-cfrr-384v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["6.3.1.1"],"introduced":["0"],"last_affected":[],"package":"shopware/core","purl":null,"source":"GHSA-qvc5-cfrr-384v"},{"ecosystem":"Packagist","fixed":["6.3.1.1"],"introduced":["0"],"last_affected":[],"package":"shopware/core","purl":"pkg:composer/shopware/core","source":"GHSA-qvc5-cfrr-384v"},{"ecosystem":"Packagist","fixed":["6.3.1.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":null,"source":"GHSA-qvc5-cfrr-384v"},{"ecosystem":"Packagist","fixed":["6.3.1.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":"pkg:composer/shopware/platform","source":"GHSA-qvc5-cfrr-384v"}],"products":null,"published":"2020-09-23","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote code execution vulnerability in a third-party library used by Shopware allows attackers to execute arbitrary code.","url":"https://insights.sbomify.com/GHSA-qvc5-cfrr-384v/"}