GHSA-qvgg-r6rq-vwfx datadog/dd-trace Circumvents open_basedir INI directive

Not scored Published

The dd-trace PHP library bypasses open_basedir restrictions, allowing access to files outside the intended directory scope.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-qvgg-r6rq-vwfx?

GHSA-qvgg-r6rq-vwfx is a vulnerability in datadog/dd-trace, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

datadog/dd-trace versions 0.30.0 prior to 0.30.2 are affected by a security and stability issue outlined in PR #579. This pull request ensures that the ddtrace.request_init_hook remains bound by the open_basedir INI directive, effectively addressing potential vulnerabilities related to open_basedir restrictions. The update introduces a sandboxing mechanism to isolate the request init hook from errors or exceptions during execution, enhancing the library's stability and preventing adverse impacts on the main script.

Which versions are affected by GHSA-qvgg-r6rq-vwfx?

2 open source packages ship an affected version, including datadog/dd-trace.

PackageAffectedFixed in
datadog/dd-trace PackagistFrom 0.30.00.30.2
datadog/dd-trace PackagistFrom 0.30.00.30.2

How do I fix GHSA-qvgg-r6rq-vwfx?

Upgrade datadog/dd-trace to 0.30.2 or later.

Is GHSA-qvgg-r6rq-vwfx being exploited?

There is no known exploitation of GHSA-qvgg-r6rq-vwfx in the wild and no public exploit code.

Sources

Is GHSA-qvgg-r6rq-vwfx in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free