GHSA-qwvp-268g-jjm8 Data Leakage Vulnerability in livewire/livewire
Not scored
Published
Check this codebase for GHSA-qwvp-268g-jjm8 and fix it if it is affected.
What it is: GHSA-qwvp-268g-jjm8 is a vulnerability in livewire/livewire, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-qwvp-268g-jjm8 in the wild and no public exploit code.
Affected packages and fixed versions:
- livewire/livewire (Packagist): affected from 2.2.5; fixed in 2.2.6
- livewire/livewire (Packagist): affected from 2.2.5; fixed in 2.2.6
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/GHSA-qwvp-268g-jjm8/ (Markdown: https://insights.sbomify.com/GHSA-qwvp-268g-jjm8/index.md)
An attacker can access unvalidated component properties via the validate method, leading to potential data leakage in Livewire applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-qwvp-268g-jjm8?
GHSA-qwvp-268g-jjm8 is a vulnerability in livewire/livewire, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
livewire/livewire versions greater than 2.2.4 and less than 2.2.6 are affected by a data leakage vulnerability. The
$this->validate() method, which is expected to return only the validated dataset, was returning all properties of the Livewire component. This regression introduced a security risk, allowing unvalidated data to be exposed, which could lead to unexpected behavior and potential security issues.Which versions are affected by GHSA-qwvp-268g-jjm8?
2 open source packages ship an affected version, including livewire/livewire.
| Package | Affected | Fixed in |
|---|---|---|
livewire/livewire Packagist | From 2.2.5 | 2.2.6 |
livewire/livewire Packagist | From 2.2.5 | 2.2.6 |
How do I fix GHSA-qwvp-268g-jjm8?
Upgrade livewire/livewire to 2.2.6 or later.
Is GHSA-qwvp-268g-jjm8 being exploited?
There is no known exploitation of GHSA-qwvp-268g-jjm8 in the wild and no public exploit code.