{"answers":{"affected":"2 open source packages ship an affected version, including esm.","exploited":"There is no known exploitation of GHSA-qx4v-6gc5-f2vv in the wild and no public exploit code.","fix":"Upgrade esm to 3.1.0 or later.","what":"GHSA-qx4v-6gc5-f2vv is a denial of service vulnerability in esm, published on 20 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qx4v-6gc5-f2vv and fix it if it is affected.\n\nWhat it is: GHSA-qx4v-6gc5-f2vv is a denial of service vulnerability in esm, published on 20 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qx4v-6gc5-f2vv in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- esm (npm): affected all versions; fixed in 3.1.0\n- esm (npm): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qx4v-6gc5-f2vv/ (Markdown: https://insights.sbomify.com/GHSA-qx4v-6gc5-f2vv/index.md)","id":"GHSA-qx4v-6gc5-f2vv","markdown":"https://insights.sbomify.com/GHSA-qx4v-6gc5-f2vv/index.md","name":"GHSA-qx4v-6gc5-f2vv","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm esm library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the esm library by triggering an infinite loop via crafted input.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A Regular Expression Denial of Service vulnerability was discovered in esm before 3.1.0. The issue is that esm's find-indexes is using the unescaped identifiers in a regex, which, in this case, causes an infinite loop.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Regular Expression Denial of Service","id":"GHSA-qx4v-6gc5-f2vv","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"esm","purl":null,"source":"GHSA-qx4v-6gc5-f2vv"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"esm","purl":"pkg:npm/esm","source":"GHSA-qx4v-6gc5-f2vv"}],"products":null,"published":"2019-06-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service in applications using the esm library by triggering an infinite loop via crafted input.","url":"https://insights.sbomify.com/GHSA-qx4v-6gc5-f2vv/"}