{"answers":{"affected":"4 open source packages ship an affected version, including opensource-workshop/connect-cms.","exploited":"There is no known exploitation of GHSA-qxh3-jgvh-x55j in the wild and no public exploit code.","fix":"Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.7.2 or 2.3.2.","what":"GHSA-qxh3-jgvh-x55j is a vulnerability in opensource-workshop/connect-cms, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-qxh3-jgvh-x55j and fix it if it is affected.\n\nWhat it is: GHSA-qxh3-jgvh-x55j is a vulnerability in opensource-workshop/connect-cms, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-qxh3-jgvh-x55j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.7.2\n- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.7.2\n- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.3.2\n- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-qxh3-jgvh-x55j/ (Markdown: https://insights.sbomify.com/GHSA-qxh3-jgvh-x55j/index.md)","id":"GHSA-qxh3-jgvh-x55j","markdown":"https://insights.sbomify.com/GHSA-qxh3-jgvh-x55j/index.md","name":"GHSA-qxh3-jgvh-x55j","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Connect-CMS","requires_auth":"low_privilege","summary":"Attackers can escalate privileges in Connect-CMS management system, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact（影響）\n\nThere is a Privilege Escalation Vulnerability on the management system of Connect-CMS.\nAffercted Version : Connect-CMS 1.7.1, 2.3.1 and earlier\n\n### Patches（修正バージョン）\n\nversion 1.7.2, 2.3.1\n\n### Workarounds（運用回避手段）\n\nUpgrade Connect-CMS to latest version","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Connect-CMS Privilege Escalation Vulnerability","id":"GHSA-qxh3-jgvh-x55j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"privilege_escalation","year":"2023"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-qxh3-jgvh-x55j"},{"ecosystem":"Packagist","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-qxh3-jgvh-x55j"},{"ecosystem":"Packagist","fixed":["2.3.2"],"introduced":["2.0.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-qxh3-jgvh-x55j"},{"ecosystem":"Packagist","fixed":["2.3.2"],"introduced":["2.0.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-qxh3-jgvh-x55j"}],"products":null,"published":"2023-07-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can escalate privileges in Connect-CMS management system, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/GHSA-qxh3-jgvh-x55j/"}